{"answers":{"affected":"6 open source packages ship an affected version, including typo3/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-6148 in the wild and no public exploit code.","fix":"Upgrade typo3/cms to a fixed version for your release line: 4.5.21, 4.6.14 or 4.7.6.","what":"CVE-2012-6148 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 1 Jul 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-6148 and fix it if it is affected.\n\nWhat it is: CVE-2012-6148 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 1 Jul 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-6148 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.21\n- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.21\n- typo3/cms (Packagist): affected from 4.6.0; fixed in 4.6.14\n- typo3/cms (Packagist): affected from 4.6.0; fixed in 4.6.14\n- typo3/cms (Packagist): affected from 4.7.0; fixed in 4.7.6\n- typo3/cms (Packagist): affected from 4.7.0; fixed in 4.7.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-6148/ (Markdown: https://insights.sbomify.com/CVE-2012-6148/index.md)","id":"CVE-2012-6148","markdown":"https://insights.sbomify.com/CVE-2012-6148/index.md","name":"CVE-2012-6148","record":{"aliases":["GHSA-rgf6-9q7g-55qg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 CMS","requires_auth":"low_privilege","summary":"Authenticated backend users can inject arbitrary scripts via the function menu API, potentially compromising other users' sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"typo3","vendor":"typo3"}],"cvss":{"score":3.5,"severity":"low","source":"nvd","vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the function menu API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Typo3 Function Menu API XSS Vulnerability","id":"CVE-2012-6148","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"typo3:typo3","products":["typo3:typo3"],"type":"xss","year":"2012"},"n_packages":6,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2012-6149"},"packages":[{"ecosystem":"Packagist","fixed":["4.5.21"],"introduced":["4.5.0"],"last_affected":[],"package":"typo3/cms","purl":null,"source":"GHSA-rgf6-9q7g-55qg"},{"ecosystem":"Packagist","fixed":["4.5.21"],"introduced":["4.5.0"],"last_affected":[],"package":"typo3/cms","purl":"pkg:composer/typo3/cms","source":"GHSA-rgf6-9q7g-55qg"},{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["4.6.0"],"last_affected":[],"package":"typo3/cms","purl":null,"source":"GHSA-rgf6-9q7g-55qg"},{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["4.6.0"],"last_affected":[],"package":"typo3/cms","purl":"pkg:composer/typo3/cms","source":"GHSA-rgf6-9q7g-55qg"},{"ecosystem":"Packagist","fixed":["4.7.6"],"introduced":["4.7.0"],"last_affected":[],"package":"typo3/cms","purl":null,"source":"GHSA-rgf6-9q7g-55qg"},{"ecosystem":"Packagist","fixed":["4.7.6"],"introduced":["4.7.0"],"last_affected":[],"package":"typo3/cms","purl":"pkg:composer/typo3/cms","source":"GHSA-rgf6-9q7g-55qg"}],"prev":{"headline":"Typo3 Backend API XSS Vulnerability","id":"CVE-2012-6147"},"products":["n/a"],"published":"2013-07-01","related":[{"cvss_score":10,"headline":"Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection","id":"CVE-2009-0258","kev_date_added":null,"published":"2009-01-22"},{"cvss_score":9.8,"headline":"Typo3 SQL injection due to faulty prepared statements","id":"CVE-2011-3583","kev_date_added":null,"published":"2019-11-25"},{"cvss_score":9.8,"headline":"Typo3 Authentication Bypass","id":"CVE-2011-4628","kev_date_added":null,"published":"2019-11-06"},{"cvss_score":8.8,"headline":"Persisted Cross-Site Scripting in Frontend Rendering in typo3","id":"CVE-2023-24814","kev_date_added":null,"published":"2023-02-07"},{"cvss_score":8.8,"headline":"Cross-Site-Request-Forgery in Backend URI Handling in Typo3","id":"CVE-2021-41113","kev_date_added":null,"published":"2021-10-05"},{"cvss_score":8.8,"headline":"Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS","id":"CVE-2020-15098","kev_date_added":null,"published":"2020-07-29"},{"cvss_score":8.8,"headline":"Deserialization of Untrusted Data in TYPO3 CMS","id":"CVE-2020-11067","kev_date_added":null,"published":"2020-05-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated backend users can inject arbitrary scripts via the function menu API, potentially compromising other users' sessions.","url":"https://insights.sbomify.com/CVE-2012-6148/"}