CVE-2012-6432 Symfony Access Control Vulnerability
Remote attackers can access arbitrary services via internal routes when enabled, bypassing authorization controls in the Symfony PHP framework.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-6432?
CVE-2012-6432 is a medium-severity missing authorization vulnerability in Sensiolabs Symfony, published on 27 Dec 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony 2.0.x before 2.0.20, 2.1.x before 2.1.5, and 2.2-dev, when the internal routes configuration is enabled, allows remote attackers to access arbitrary services via vectors involving a URI beginning with a /_internal substring.
Weakness: CWE-264
Which versions are affected by CVE-2012-6432?
6 open source packages ship an affected version, including symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/symfony Packagist | All versions | None |
symfony/symfony Packagist | All versions | None |
symfony/symfony Packagist | From 2.0.0 | 2.0.20 |
symfony/symfony Packagist | From 2.0.0 | 2.0.20 |
symfony/symfony Packagist | From 2.1.0 | 2.1.5 |
symfony/symfony Packagist | From 2.1.0 | 2.1.5 |
Products include Sensiolabs Symfony.
How do I fix CVE-2012-6432?
Upgrade symfony/symfony to a fixed version for your release line: 2.0.20 or 2.1.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2012-6432 being exploited?
There is no known exploitation of CVE-2012-6432 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as GHSA-89cp-fvcc-hxh7.