# CVE-2012-6432: Symfony Access Control Vulnerability

> Remote attackers can access arbitrary services via internal routes when enabled, bypassing authorization controls in the Symfony PHP framework.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Dec 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-89cp-fvcc-hxh7

## What is CVE-2012-6432?

CVE-2012-6432 is a medium-severity missing authorization vulnerability in Sensiolabs Symfony, published on 27 Dec 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Symfony 2.0.x before 2.0.20, 2.1.x before 2.1.5, and 2.2-dev, when the internal routes configuration is enabled, allows remote attackers to access arbitrary services via vectors involving a URI beginning with a /_internal substring.

Weakness: CWE-264

## Which versions are affected by CVE-2012-6432?

6 open source packages ship an affected version, including symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/symfony` | Packagist | All versions | None |
| `symfony/symfony` | Packagist | All versions | None |
| `symfony/symfony` | Packagist | From 2.0.0 | 2.0.20 |
| `symfony/symfony` | Packagist | From 2.0.0 | 2.0.20 |
| `symfony/symfony` | Packagist | From 2.1.0 | 2.1.5 |
| `symfony/symfony` | Packagist | From 2.1.0 | 2.1.5 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2012-6432?

Upgrade symfony/symfony to a fixed version for your release line: 2.0.20 or 2.1.5.

## Is CVE-2012-6432 being exploited?

There is no known exploitation of CVE-2012-6432 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-6432 and fix it if it is affected.

What it is: CVE-2012-6432 is a medium-severity missing authorization vulnerability in Sensiolabs Symfony, published on 27 Dec 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-6432 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/symfony (Packagist): affected all versions; no fix listed
- symfony/symfony (Packagist): affected all versions; no fix listed
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 2.0.20
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 2.0.20
- symfony/symfony (Packagist): affected from 2.1.0; fixed in 2.1.5
- symfony/symfony (Packagist): affected from 2.1.0; fixed in 2.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-6432/ (Markdown: https://insights.sbomify.com/CVE-2012-6432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-6432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-6432
- OSV: https://osv.dev/vulnerability/CVE-2012-6432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-6432/
Summaries are generated and may contain mistakes; the official description above is the record.
