# CVE-2012-6551: Apache ActiveMQ default configuration subject to denial of service

> Remote attackers can cause denial of service in Apache ActiveMQ via HTTP requests due to a default sample web application.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-34fp-xvxp-rg22

## What is CVE-2012-6551?

CVE-2012-6551 is a medium-severity denial of service vulnerability in Apache Activemq, published on 21 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The default configuration of Apache ActiveMQ before 5.8.0 enables a sample web application, which allows remote attackers to cause a denial of service (broker resource consumption) via HTTP requests.

Weakness: CWE-399

## Which versions are affected by CVE-2012-6551?

4 open source packages ship an affected version, including org.apache.activemq:activemq-web-demo and org.apache.activemq:apache-activemq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-web-demo` | Maven | All versions | 5.8.0 |
| `org.apache.activemq:activemq-web-demo` | Maven | All versions | 5.8.0 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.8.0 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.8.0 |

Products: Apache Activemq.

## How do I fix CVE-2012-6551?

Upgrade org.apache.activemq:activemq-web-demo to 5.8.0 or later.

## Is CVE-2012-6551 being exploited?

There is no known exploitation of CVE-2012-6551 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-6551 and fix it if it is affected.

What it is: CVE-2012-6551 is a medium-severity denial of service vulnerability in Apache Activemq, published on 21 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-6551 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-web-demo (Maven): affected all versions; fixed in 5.8.0
- org.apache.activemq:activemq-web-demo (Maven): affected all versions; fixed in 5.8.0
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.8.0
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-6551/ (Markdown: https://insights.sbomify.com/CVE-2012-6551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-6551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-6551
- OSV: https://osv.dev/vulnerability/CVE-2012-6551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-6551/
Summaries are generated and may contain mistakes; the official description above is the record.
