# CVE-2012-6612: Improper Restriction of XML External Entity Reference in Apache Solr

> Remote attackers can exploit XML External Entity vulnerabilities in Apache Solr to read sensitive data or cause denial of service.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-6612, GHSA-6cpj-3g83-q2j4

## What is CVE-2012-6612?

CVE-2012-6612 is a high-severity vulnerability in n/a, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The (1) UpdateRequestHandler for XSLT or (2) XPathEntityProcessor in Apache Solr before 4.1 allows remote attackers to have an unspecified impact via XML data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue, different vectors than CVE-2013-6407.

## Which versions are affected by CVE-2012-6612?

2 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | All versions | 4.1.0 |
| `org.apache.solr:solr-core` | Maven | All versions | 4.1.0 |

Products: Apache Solr.

## How do I fix CVE-2012-6612?

Upgrade org.apache.solr:solr-core to 4.1.0 or later.

## Is CVE-2012-6612 being exploited?

There is no known exploitation of CVE-2012-6612 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-6612 and fix it if it is affected.

What it is: CVE-2012-6612 is a high-severity vulnerability in n/a, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-6612 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 4.1.0
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-6612/ (Markdown: https://insights.sbomify.com/CVE-2012-6612/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-6612
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-6612
- OSV: https://osv.dev/vulnerability/CVE-2012-6612

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-6612/
Summaries are generated and may contain mistakes; the official description above is the record.
