CVE-2012-6661 Plone and Zope2 do not reseed pseudo-random number generator
Remote attackers can guess pseudo-random values due to lack of PRNG reseeding, potentially bypassing security controls in Zope and Plone.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-6661?
CVE-2012-6661 is a medium-severity vulnerability in Plone Plone, published on 3 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Zope before 2.13.19, as used in Plone before 4.2.3 and 4.3 before beta 1, does not reseed the pseudo-random number generator (PRNG), which makes it easier for remote attackers to guess the value via unspecified vectors. NOTE: this issue was SPLIT from CVE-2012-5508 due to different vulnerability types (ADT2).
Weakness: CWE-310
Which versions are affected by CVE-2012-6661?
8 open source packages ship an affected version, including plone, Plone and Zope2. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | All versions | 4.2.3, 4.3b1 |
plone PyPI | From 3.2.2 | 4.2.3 |
plone PyPI | From 4.3a1 | 4.3b1 |
Plone PyPI | From 3.2.2 | 4.2.3 |
Plone PyPI | From 4.3a1 | 4.3b1 |
Zope2 PyPI | All versions | 2.13.19 |
2 more packages
zope2 PyPI | All versions | 2.13.19 |
zope2 PyPI | All versions | 2.13.19 |
Products include Plone Plone, Zope Zope.
How do I fix CVE-2012-6661?
Upgrade plone to a fixed version for your release line: 4.2.3 or 4.3b1.
Is CVE-2012-6661 being exploited?
There is no known exploitation of CVE-2012-6661 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-48vv-2pmq-9fvv, PYSEC-2014-51, PYSEC-2014-76.