{"answers":{"affected":"8 open source packages ship an affected version, including org.webjars.npm:jquery-ui, jQuery.UI.Combined and jquery-ui-rails. It affects 5 products.","exploited":"There is no known exploitation of CVE-2012-6662 in the wild and no public exploit code.","fix":"Upgrade org.webjars.npm:jquery-ui to 1.10.0 or later.","what":"CVE-2012-6662 is a medium-severity cross-site scripting vulnerability in Redhat Enterprise Linux Desktop, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-6662 and fix it if it is affected.\n\nWhat it is: CVE-2012-6662 is a medium-severity cross-site scripting vulnerability in Redhat Enterprise Linux Desktop, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-6662 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.webjars.npm:jquery-ui (Maven): affected all versions; fixed in 1.10.0\n- org.webjars.npm:jquery-ui (Maven): affected all versions; fixed in 1.10.0\n- jQuery.UI.Combined (NuGet): affected all versions; fixed in 1.10.0\n- jQuery.UI.Combined (NuGet): affected all versions; fixed in 1.10.0\n- jquery-ui-rails (RubyGems): affected all versions; fixed in 4.0.0\n- jquery-ui-rails (RubyGems): affected all versions; fixed in 4.0.0\n- jquery-ui (npm): affected all versions; fixed in 1.10.0\n- jquery-ui (npm): affected all versions; fixed in 1.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-6662/ (Markdown: https://insights.sbomify.com/CVE-2012-6662/index.md)","id":"CVE-2012-6662","markdown":"https://insights.sbomify.com/CVE-2012-6662/index.md","name":"CVE-2012-6662","record":{"aliases":["DEBIAN-CVE-2012-6662","GHSA-qqxp-xp9v-vvx6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"jQuery UI library","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the title attribute in the jQuery UI Tooltip widget, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jquery_ui","vendor":"jqueryui"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_hpc_node","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the default content option in jquery.ui.tooltip.js in the Tooltip widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title attribute, which is not properly handled in the autocomplete combo box demo.","ecosystems":["Maven","NuGet","RubyGems","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"jquery-ui Tooltip widget vulnerable to XSS","id":"CVE-2012-6662","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"redhat:enterprise_linux_desktop","products":["redhat:enterprise_linux_desktop","redhat:enterprise_linux_hpc_node","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"xss","year":"2012"},"n_packages":8,"n_references":11,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2012-6663"},"packages":[{"ecosystem":"Maven","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"org.webjars.npm:jquery-ui","purl":null,"source":"GHSA-qqxp-xp9v-vvx6"},{"ecosystem":"Maven","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"org.webjars.npm:jquery-ui","purl":"pkg:maven/org.webjars.npm/jquery-ui","source":"GHSA-qqxp-xp9v-vvx6"},{"ecosystem":"NuGet","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"jQuery.UI.Combined","purl":null,"source":"GHSA-qqxp-xp9v-vvx6"},{"ecosystem":"NuGet","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"jQuery.UI.Combined","purl":"pkg:nuget/jQuery.UI.Combined","source":"GHSA-qqxp-xp9v-vvx6"},{"ecosystem":"RubyGems","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"jquery-ui-rails","purl":null,"source":"GHSA-qqxp-xp9v-vvx6"},{"ecosystem":"RubyGems","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"jquery-ui-rails","purl":"pkg:gem/jquery-ui-rails","source":"GHSA-qqxp-xp9v-vvx6"},{"ecosystem":"npm","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"jquery-ui","purl":null,"source":"GHSA-qqxp-xp9v-vvx6"},{"ecosystem":"npm","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"jquery-ui","purl":"pkg:npm/jquery-ui","source":"GHSA-qqxp-xp9v-vvx6"}],"prev":{"headline":"Plone and Zope2 do not reseed pseudo-random number generator","id":"CVE-2012-6661"},"products":["n/a"],"published":"2014-11-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the title attribute in the jQuery UI Tooltip widget, requiring user interaction to execute.","url":"https://insights.sbomify.com/CVE-2012-6662/"}