# CVE-2012-6684: RedCloth Cross-site Scripting vulnerability

> Remote attackers can inject arbitrary web script or HTML via javascript URIs in the RedCloth Ruby library, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jan 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-6684, DLA-167-1, DSA-3168-1, GHSA-r23g-3qw4-gfh2, openSUSE-SU-2024:10401-1

## What is CVE-2012-6684?

CVE-2012-6684 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 8 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-6684?

2 open source packages ship an affected version, including RedCloth. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `RedCloth` | RubyGems | All versions | 4.3.0 |
| `RedCloth` | RubyGems | All versions | 4.3.0 |

Products: Debian Debian Linux, Redcloth Redcloth Library.

## How do I fix CVE-2012-6684?

Upgrade RedCloth to 4.3.0 or later.

## Is CVE-2012-6684 being exploited?

There is no known exploitation of CVE-2012-6684 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-6684 and fix it if it is affected.

What it is: CVE-2012-6684 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 8 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-6684 in the wild and no public exploit code.

Affected packages and fixed versions:
- RedCloth (RubyGems): affected all versions; fixed in 4.3.0
- RedCloth (RubyGems): affected all versions; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-6684/ (Markdown: https://insights.sbomify.com/CVE-2012-6684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-6684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-6684
- OSV: https://osv.dev/vulnerability/CVE-2012-6684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-6684/
Summaries are generated and may contain mistakes; the official description above is the record.
