{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 8 products.","exploited":"There is no known exploitation of CVE-2012-6685 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.5.4 or later.","what":"CVE-2012-6685 is a high-severity vulnerability in Redhat Enterprise Mrg, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-6685 and fix it if it is affected.\n\nWhat it is: CVE-2012-6685 is a high-severity vulnerability in Redhat Enterprise Mrg, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-6685 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.5.4\n- nokogiri (RubyGems): affected all versions; fixed in 1.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-6685/ (Markdown: https://insights.sbomify.com/CVE-2012-6685/index.md)","id":"CVE-2012-6685","markdown":"https://insights.sbomify.com/CVE-2012-6685/index.md","name":"CVE-2012-6685","record":{"aliases":["DEBIAN-CVE-2012-6685","DLA-229-1","GHSA-6wj9-77wq-jq7p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML library","requires_auth":"none","summary":"An attacker can exploit XML External Entity vulnerabilities in Nokogiri to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"nokogiri","vendor":"nokogiri"},{"product":"cloudforms_management_engine","vendor":"redhat"},{"product":"enterprise_mrg","vendor":"redhat"},{"product":"openshift","vendor":"redhat"},{"product":"openstack","vendor":"redhat"},{"product":"openstack_foreman","vendor":"redhat"},{"product":"satellite","vendor":"redhat"},{"product":"subscription_asset_manager","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-776","name":"Improper Restriction of Recursive Entity References in DTDs"}],"description":"Nokogiri before 1.5.4 is vulnerable to XXE attacks","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Nokogiri is vulnerable to XML External Entity (XXE) attack","id":"CVE-2012-6685","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"redhat:enterprise_mrg","products":["redhat:enterprise_mrg","redhat:openshift","redhat:openstack","redhat:satellite"],"type":"xxe","year":"2012"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2012-6687"},"packages":[{"ecosystem":"RubyGems","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-6wj9-77wq-jq7p"},{"ecosystem":"RubyGems","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-6wj9-77wq-jq7p"}],"prev":{"headline":"RedCloth Cross-site Scripting vulnerability","id":"CVE-2012-6684"},"products":["n/a"],"published":"2020-02-19","related":[{"cvss_score":8.7,"headline":"Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer","id":"CVE-2026-79770","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":7.5,"headline":"Unchecked return value from xmlTextReaderExpand in Nokogiri","id":"CVE-2022-23476","kev_date_added":null,"published":"2022-12-08"},{"cvss_score":7.5,"headline":"Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby","id":"CVE-2021-41098","kev_date_added":null,"published":"2021-09-27"},{"cvss_score":6.9,"headline":"Nokogiri before 1.19.3 Memory Leak via XSLT Transform","id":"CVE-2026-79771","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":6.9,"headline":"Nokogiri before 1.19.1 Unchecked Return Value canonicalize","id":"CVE-2026-79772","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":6.3,"headline":"Nokogiri: Possible Out-of-Bounds Read in `Nokogiri::XML::NodeSet#[]`","id":"CVE-2026-57235","kev_date_added":null,"published":"2026-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"An attacker can exploit XML External Entity vulnerabilities in Nokogiri to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2012-6685/"}