CVE-2012-6708 Cross-Site Scripting in jquery

Medium 6.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2012-6708?

CVE-2012-6708 is a medium-severity vulnerability in n/a, published on 18 Jan 2018.

Official description

jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '<' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '<' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.

Weakness: CWE-79

Which versions are affected by CVE-2012-6708?

8 open source packages ship an affected version, including org.webjars.npm:jquery, jQuery and jquery-rails. It affects 1 product.

PackageAffectedFixed in
org.webjars.npm:jquery MavenAll versions1.9.0
org.webjars.npm:jquery MavenAll versions1.9.0
jQuery NuGetAll versions1.9.0
jQuery NuGetAll versions1.9.0
jquery-rails RubyGemsAll versions2.2.0
jquery-rails RubyGemsAll versions2.2.0
2 more packages
jquery npmAll versions1.9.0
jquery npmAll versions1.9.0

Products include Jquery Jquery.

How do I fix CVE-2012-6708?

Upgrade org.webjars.npm:jquery to 1.9.0 or later.

Is CVE-2012-6708 being exploited?

There is no known exploitation of CVE-2012-6708 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as ALPINE-CVE-2012-6708, AZL-40951, AZL-43897, AZL-44730, AZL-44937, CLSA-2026-1777336744 and 3 more.

Is CVE-2012-6708 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free