{"answers":{"affected":"8 open source packages ship an affected version, including org.webjars.npm:jquery, jQuery and jquery-rails. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-6708 in the wild and no public exploit code.","fix":"Upgrade org.webjars.npm:jquery to 1.9.0 or later.","what":"CVE-2012-6708 is a medium-severity vulnerability in n/a, published on 18 Jan 2018."},"fix_prompt":"Check this codebase for CVE-2012-6708 and fix it if it is affected.\n\nWhat it is: CVE-2012-6708 is a medium-severity vulnerability in n/a, published on 18 Jan 2018. \nExploitation: There is no known exploitation of CVE-2012-6708 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.webjars.npm:jquery (Maven): affected all versions; fixed in 1.9.0\n- org.webjars.npm:jquery (Maven): affected all versions; fixed in 1.9.0\n- jQuery (NuGet): affected all versions; fixed in 1.9.0\n- jQuery (NuGet): affected all versions; fixed in 1.9.0\n- jquery-rails (RubyGems): affected all versions; fixed in 2.2.0\n- jquery-rails (RubyGems): affected all versions; fixed in 2.2.0\n- jquery (npm): affected all versions; fixed in 1.9.0\n- jquery (npm): affected all versions; fixed in 1.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-6708/ (Markdown: https://insights.sbomify.com/CVE-2012-6708/index.md)","id":"CVE-2012-6708","markdown":"https://insights.sbomify.com/CVE-2012-6708/index.md","name":"CVE-2012-6708","record":{"aliases":["ALPINE-CVE-2012-6708","AZL-40951","AZL-43897","AZL-44730","AZL-44937","CLSA-2026-1777336744","CVE-2017-16011","GHSA-2pqj-h3vj-pqgw","UBUNTU-CVE-2012-6708"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"jquery","vendor":"jquery"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '\u003c' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '\u003c' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.","ecosystems":["Maven","NuGet","RubyGems","npm"],"exploits":{"exploitdb":1,"first_seen":"2021-03-25","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-03-25","kind":"exploitdb","ref":"49708","stars":null,"title":"Linksys EA7500 2.0.8.194281 - Cross-Site Scripting"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Cross-Site Scripting in jquery","id":"CVE-2012-6708","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":null,"year":"2012"},"n_packages":8,"n_references":11,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2012-6709"},"packages":[{"ecosystem":"Maven","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"org.webjars.npm:jquery","purl":null,"source":"GHSA-2pqj-h3vj-pqgw"},{"ecosystem":"Maven","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"org.webjars.npm:jquery","purl":"pkg:maven/org.webjars.npm/jquery","source":"GHSA-2pqj-h3vj-pqgw"},{"ecosystem":"NuGet","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"jQuery","purl":null,"source":"GHSA-2pqj-h3vj-pqgw"},{"ecosystem":"NuGet","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"jQuery","purl":"pkg:nuget/jQuery","source":"GHSA-2pqj-h3vj-pqgw"},{"ecosystem":"RubyGems","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"jquery-rails","purl":null,"source":"GHSA-2pqj-h3vj-pqgw"},{"ecosystem":"RubyGems","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"jquery-rails","purl":"pkg:gem/jquery-rails","source":"GHSA-2pqj-h3vj-pqgw"},{"ecosystem":"npm","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"jquery","purl":null,"source":"GHSA-2pqj-h3vj-pqgw"},{"ecosystem":"npm","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"jquery","purl":"pkg:npm/jquery","source":"GHSA-2pqj-h3vj-pqgw"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2012-6707"},"products":["n/a"],"published":"2018-01-18","related":[{"cvss_score":7.5,"headline":"Denial of Service in jquery","id":"CVE-2016-10707","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":6.1,"headline":"Cross-Site Scripting in jquery","id":"CVE-2020-7656","kev_date_added":null,"published":"2020-05-19"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2018-18405","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":6.1,"headline":"Cross-Site Scripting (XSS) in jquery","id":"CVE-2015-9251","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2014-6071","kev_date_added":null,"published":"2018-01-16"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2007-2379","kev_date_added":null,"published":"2007-04-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2012-6708/"}