{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2012-6711 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2012-6711 is a high-severity memory corruption vulnerability in Redhat Enterprise Linux, published on 18 Jun 2019. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-6711 and fix it if it is affected.\n\nWhat it is: CVE-2012-6711 is a high-severity memory corruption vulnerability in Redhat Enterprise Linux, published on 18 Jun 2019. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-6711 in the wild and no public exploit code.\n\nAffected product: Redhat Enterprise Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-6711/ (Markdown: https://insights.sbomify.com/CVE-2012-6711/index.md)","id":"CVE-2012-6711","markdown":"https://insights.sbomify.com/CVE-2012-6711/index.md","name":"CVE-2012-6711","record":{"aliases":["DEBIAN-CVE-2012-6711","GHSA-rwf6-27gf-7q62","SUSE-SU-2019:2976-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GNU Bash shell","requires_auth":"low_privilege","summary":"A heap-based buffer overflow in GNU Bash allows local attackers to execute arbitrary code or crash scripts via crafted echo commands.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bash","vendor":"gnu"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.0/AC:H/AV:L/A:H/C:H/I:H/PR:L/S:U/UI:N","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A heap-based buffer overflow exists in GNU Bash before 4.3 when wide characters, not supported by the current locale set in the LC_CTYPE environment variable, are printed through the echo built-in function. A local attacker, who can provide data to print through the \"echo -e\" built-in function, may use this flaw to crash a script or execute code with the privileges of the bash process. This occurs because ansicstr() in lib/sh/strtrans.c mishandles u32cconv().","ecosystems":["SUSE:Linux Enterprise Server 12 SP1-LTSS","SUSE:Linux Enterprise Server for SAP Applications 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2012-6711","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"redhat:enterprise_linux","products":["redhat:enterprise_linux"],"type":"memory_corruption","year":"2012"},"n_packages":2,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2012-6712"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1-LTSS","fixed":["4.2-83.6.1"],"introduced":["0"],"last_affected":[],"package":"bash","purl":"pkg:rpm/suse/bash\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1-LTSS","source":"SUSE-SU-2019:2976-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["4.2-83.6.1"],"introduced":["0"],"last_affected":[],"package":"bash","purl":"pkg:rpm/suse/bash\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2019:2976-1"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2012-6710"},"products":["n/a"],"published":"2019-06-18","related":[{"cvss_score":8.8,"headline":"GNU Bash OS Command Injection","id":"CVE-2014-6278","kev_date_added":"2025-10-02","published":"2014-09-30"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2014-7186","kev_date_added":null,"published":"2014-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2014-7187","kev_date_added":null,"published":"2014-09-28"},{"cvss_score":10,"headline":"Code injection in n/a","id":"CVE-2014-6277","kev_date_added":null,"published":"2014-09-27"},{"cvss_score":7.8,"headline":"Memory corruption in bash","id":"CVE-2022-3715","kev_date_added":null,"published":"2023-01-05"},{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2019-18276","kev_date_added":null,"published":"2019-11-28"},{"cvss_score":7.8,"headline":"Command injection in n/a","id":"CVE-2017-5932","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A heap-based buffer overflow in GNU Bash allows local attackers to execute arbitrary code or crash scripts via crafted echo commands.","url":"https://insights.sbomify.com/CVE-2012-6711/"}