{"answers":{"affected":"6 open source packages ship an affected version, including activerecord. It affects 3 products.","exploited":"There is no known exploitation of CVE-2013-0155 in the wild and no public exploit code.","fix":"Upgrade activerecord to a fixed version for your release line: 3.0.19, 3.1.10 or 3.2.11.","what":"CVE-2013-0155 is a medium-severity SQL injection vulnerability in Debian Debian Linux, published on 13 Jan 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-0155 and fix it if it is affected.\n\nWhat it is: CVE-2013-0155 is a medium-severity SQL injection vulnerability in Debian Debian Linux, published on 13 Jan 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-0155 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activerecord (RubyGems): affected from 3.0.0; fixed in 3.0.19\n- activerecord (RubyGems): affected from 3.0.0; fixed in 3.0.19\n- activerecord (RubyGems): affected from 3.1.0; fixed in 3.1.10\n- activerecord (RubyGems): affected from 3.1.0; fixed in 3.1.10\n- activerecord (RubyGems): affected from 3.2.0; fixed in 3.2.11\n- activerecord (RubyGems): affected from 3.2.0; fixed in 3.2.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-0155/ (Markdown: https://insights.sbomify.com/CVE-2013-0155/index.md)","id":"CVE-2013-0155","markdown":"https://insights.sbomify.com/CVE-2013-0155/index.md","name":"CVE-2013-0155","record":{"aliases":["DEBIAN-CVE-2013-0155","DSA-2609-1","GHSA-gppp-5xc5-wfpx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails framework","requires_auth":"none","summary":"Remote attackers can bypass database restrictions and manipulate queries via crafted JSON requests, potentially reading or modifying data.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":6.4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Ruby on Rails 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly consider differences in parameter handling between the Active Record component and the JSON implementation, which allows remote attackers to bypass intended database-query restrictions and perform NULL checks or trigger missing WHERE clauses via a crafted request, as demonstrated by certain \"[nil]\" values, a related issue to CVE-2012-2660 and CVE-2012-2694.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Active Record allows bypassing of database-query restrictions","id":"CVE-2013-0155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","rubyonrails:rails"],"type":"sql_injection","year":"2013"},"n_packages":6,"n_references":12,"next":{"headline":"actionpack Improper Input Validation vulnerability","id":"CVE-2013-0156"},"packages":[{"ecosystem":"RubyGems","fixed":["3.0.19"],"introduced":["3.0.0"],"last_affected":[],"package":"activerecord","purl":null,"source":"GHSA-gppp-5xc5-wfpx"},{"ecosystem":"RubyGems","fixed":["3.0.19"],"introduced":["3.0.0"],"last_affected":[],"package":"activerecord","purl":"pkg:gem/activerecord","source":"GHSA-gppp-5xc5-wfpx"},{"ecosystem":"RubyGems","fixed":["3.1.10"],"introduced":["3.1.0"],"last_affected":[],"package":"activerecord","purl":null,"source":"GHSA-gppp-5xc5-wfpx"},{"ecosystem":"RubyGems","fixed":["3.1.10"],"introduced":["3.1.0"],"last_affected":[],"package":"activerecord","purl":"pkg:gem/activerecord","source":"GHSA-gppp-5xc5-wfpx"},{"ecosystem":"RubyGems","fixed":["3.2.11"],"introduced":["3.2.0"],"last_affected":[],"package":"activerecord","purl":null,"source":"GHSA-gppp-5xc5-wfpx"},{"ecosystem":"RubyGems","fixed":["3.2.11"],"introduced":["3.2.0"],"last_affected":[],"package":"activerecord","purl":"pkg:gem/activerecord","source":"GHSA-gppp-5xc5-wfpx"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2013-0154"},"products":["n/a"],"published":"2013-01-13","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass database restrictions and manipulate queries via crafted JSON requests, potentially reading or modifying data.","url":"https://insights.sbomify.com/CVE-2013-0155/"}