# CVE-2013-0155: Active Record allows bypassing of database-query restrictions

> Remote attackers can bypass database restrictions and manipulate queries via crafted JSON requests, potentially reading or modifying data.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-0155, DSA-2609-1, GHSA-gppp-5xc5-wfpx

## What is CVE-2013-0155?

CVE-2013-0155 is a medium-severity SQL injection vulnerability in Debian Debian Linux, published on 13 Jan 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ruby on Rails 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly consider differences in parameter handling between the Active Record component and the JSON implementation, which allows remote attackers to bypass intended database-query restrictions and perform NULL checks or trigger missing WHERE clauses via a crafted request, as demonstrated by certain "[nil]" values, a related issue to CVE-2012-2660 and CVE-2012-2694.

Weakness: CWE-264

## Which versions are affected by CVE-2013-0155?

6 open source packages ship an affected version, including activerecord. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 3.0.0 | 3.0.19 |
| `activerecord` | RubyGems | From 3.0.0 | 3.0.19 |
| `activerecord` | RubyGems | From 3.1.0 | 3.1.10 |
| `activerecord` | RubyGems | From 3.1.0 | 3.1.10 |
| `activerecord` | RubyGems | From 3.2.0 | 3.2.11 |
| `activerecord` | RubyGems | From 3.2.0 | 3.2.11 |

Products: Debian Debian Linux, Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2013-0155?

Upgrade activerecord to a fixed version for your release line: 3.0.19, 3.1.10 or 3.2.11.

## Is CVE-2013-0155 being exploited?

There is no known exploitation of CVE-2013-0155 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0155 and fix it if it is affected.

What it is: CVE-2013-0155 is a medium-severity SQL injection vulnerability in Debian Debian Linux, published on 13 Jan 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0155 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 3.0.0; fixed in 3.0.19
- activerecord (RubyGems): affected from 3.0.0; fixed in 3.0.19
- activerecord (RubyGems): affected from 3.1.0; fixed in 3.1.10
- activerecord (RubyGems): affected from 3.1.0; fixed in 3.1.10
- activerecord (RubyGems): affected from 3.2.0; fixed in 3.2.11
- activerecord (RubyGems): affected from 3.2.0; fixed in 3.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0155/ (Markdown: https://insights.sbomify.com/CVE-2013-0155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0155
- OSV: https://osv.dev/vulnerability/CVE-2013-0155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0155/
Summaries are generated and may contain mistakes; the official description above is the record.
