{"answers":{"affected":"2 open source packages ship an affected version, including ruby_parser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-0162 in the wild and no public exploit code.","fix":"Upgrade ruby_parser to 3.1.2 or later.","what":"CVE-2013-0162 is a low-severity path traversal vulnerability in n/a, published on 1 Mar 2013. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-0162 and fix it if it is affected.\n\nWhat it is: CVE-2013-0162 is a low-severity path traversal vulnerability in n/a, published on 1 Mar 2013. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-0162 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby_parser (RubyGems): affected from 2.0.2; fixed in 3.1.2\n- ruby_parser (RubyGems): affected from 2.0.2; fixed in 3.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-0162/ (Markdown: https://insights.sbomify.com/CVE-2013-0162/index.md)","id":"CVE-2013-0162","markdown":"https://insights.sbomify.com/CVE-2013-0162/index.md","name":"CVE-2013-0162","record":{"aliases":["GHSA-8mvw-22r7-w6fq","UBUNTU-CVE-2013-0162"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby parser library","requires_auth":"none","summary":"Local attackers can overwrite arbitrary files via symlink attacks on predictable temporary files in the ruby_parser gem.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ruby_parser","vendor":"ryan_davis"}],"cvss":{"score":2.1,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The diff_pp function in lib/gauntlet_rubyparser.rb in the ruby_parser gem 3.1.1 and earlier for Ruby allows local users to overwrite arbitrary files via a symlink attack on a temporary file with a predictable name in /tmp.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ruby_parser allows local users to overwrite arbitrary files via symlink attack on temporary file with predictable name","id":"CVE-2013-0162","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2013"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of service in OpenShift haproxy cartridge","id":"CVE-2013-0163"},"packages":[{"ecosystem":"RubyGems","fixed":["3.1.2"],"introduced":["2.0.2"],"last_affected":[],"package":"ruby_parser","purl":null,"source":"GHSA-8mvw-22r7-w6fq"},{"ecosystem":"RubyGems","fixed":["3.1.2"],"introduced":["2.0.2"],"last_affected":[],"package":"ruby_parser","purl":"pkg:gem/ruby_parser","source":"GHSA-8mvw-22r7-w6fq"}],"prev":{"headline":"Cross-site scripting in CMS","id":"CVE-2013-0161"},"products":["n/a"],"published":"2013-03-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can overwrite arbitrary files via symlink attacks on predictable temporary files in the ruby_parser gem.","url":"https://insights.sbomify.com/CVE-2013-0162/"}