# CVE-2013-0162: ruby_parser allows local users to overwrite arbitrary files via symlink attack on temporary file with predictable name

> Local attackers can overwrite arbitrary files via symlink attacks on predictable temporary files in the ruby_parser gem.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8mvw-22r7-w6fq, UBUNTU-CVE-2013-0162

## What is CVE-2013-0162?

CVE-2013-0162 is a low-severity path traversal vulnerability in n/a, published on 1 Mar 2013. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The diff_pp function in lib/gauntlet_rubyparser.rb in the ruby_parser gem 3.1.1 and earlier for Ruby allows local users to overwrite arbitrary files via a symlink attack on a temporary file with a predictable name in /tmp.

Weakness: CWE-264

## Which versions are affected by CVE-2013-0162?

2 open source packages ship an affected version, including ruby_parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby_parser` | RubyGems | From 2.0.2 | 3.1.2 |
| `ruby_parser` | RubyGems | From 2.0.2 | 3.1.2 |

Products: Ryan Davis Ruby Parser.

## How do I fix CVE-2013-0162?

Upgrade ruby_parser to 3.1.2 or later.

## Is CVE-2013-0162 being exploited?

There is no known exploitation of CVE-2013-0162 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0162 and fix it if it is affected.

What it is: CVE-2013-0162 is a low-severity path traversal vulnerability in n/a, published on 1 Mar 2013. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0162 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby_parser (RubyGems): affected from 2.0.2; fixed in 3.1.2
- ruby_parser (RubyGems): affected from 2.0.2; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0162/ (Markdown: https://insights.sbomify.com/CVE-2013-0162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0162
- OSV: https://osv.dev/vulnerability/CVE-2013-0162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0162/
Summaries are generated and may contain mistakes; the official description above is the record.
