{"answers":{"affected":"2 open source packages ship an affected version, including multi_xml. It affects 2 products.","exploited":"There is no known exploitation of CVE-2013-0175 in the wild and no public exploit code.","fix":"Upgrade multi_xml to 0.5.2 or later.","what":"CVE-2013-0175 is a high-severity unsafe deserialization vulnerability in n/a, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-0175 and fix it if it is affected.\n\nWhat it is: CVE-2013-0175 is a high-severity unsafe deserialization vulnerability in n/a, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-0175 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multi_xml (RubyGems): affected all versions; fixed in 0.5.2\n- multi_xml (RubyGems): affected all versions; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-0175/ (Markdown: https://insights.sbomify.com/CVE-2013-0175/index.md)","id":"CVE-2013-0175","markdown":"https://insights.sbomify.com/CVE-2013-0175/index.md","name":"CVE-2013-0175","record":{"aliases":["GHSA-pchc-949f-53m5","openSUSE-SU-2024:11339-1","openSUSE-SU-2024:13164-1","openSUSE-SU-2024:14173-1","openSUSE-SU-2025:15122-1","openSUSE-SU-2026:10355-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML parsing library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code or cause denial of service via unsafe XML deserialization in the multi_xml Ruby gem.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"multi_xml","vendor":"erik_michaels-ober"},{"product":"grape","vendor":"grape_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"multi_xml gem 0.5.2 for Ruby, as used in Grape before 0.2.6 and possibly other products, does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.","ecosystems":["RubyGems","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in multi_xml","id":"CVE-2013-0175","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"deserialization","year":"2013"},"n_packages":6,"n_references":5,"next":{"headline":"Null dereference in n/a","id":"CVE-2013-0176"},"packages":[{"ecosystem":"RubyGems","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"multi_xml","purl":null,"source":"GHSA-pchc-949f-53m5"},{"ecosystem":"RubyGems","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"multi_xml","purl":"pkg:gem/multi_xml","source":"GHSA-pchc-949f-53m5"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.6.0-1.23"],"introduced":["0"],"last_affected":[],"package":"ruby3.2-rubygem-multi_xml","purl":"pkg:rpm/opensuse/ruby3.2-rubygem-multi_xml\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13164-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.6.0-1.27"],"introduced":["0"],"last_affected":[],"package":"rubygem-multi_xml","purl":"pkg:rpm/opensuse/rubygem-multi_xml\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14173-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.6.0-1.29"],"introduced":["0"],"last_affected":[],"package":"rubygem-multi_xml","purl":"pkg:rpm/opensuse/rubygem-multi_xml\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15122-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.6.0-1.31"],"introduced":["0"],"last_affected":[],"package":"rubygem-multi_xml","purl":"pkg:rpm/opensuse/rubygem-multi_xml\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10355-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2013-0174"},"products":["n/a"],"published":"2013-04-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code or cause denial of service via unsafe XML deserialization in the multi_xml Ruby gem.","url":"https://insights.sbomify.com/CVE-2013-0175/"}