# CVE-2013-0175: Improper Input Validation in multi_xml

> Remote attackers can execute arbitrary code or cause denial of service via unsafe XML deserialization in the multi_xml Ruby gem.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-pchc-949f-53m5, openSUSE-SU-2024:11339-1, openSUSE-SU-2024:13164-1, openSUSE-SU-2024:14173-1, openSUSE-SU-2025:15122-1, openSUSE-SU-2026:10355-1

## What is CVE-2013-0175?

CVE-2013-0175 is a high-severity unsafe deserialization vulnerability in n/a, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

multi_xml gem 0.5.2 for Ruby, as used in Grape before 0.2.6 and possibly other products, does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-0175?

2 open source packages ship an affected version, including multi_xml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multi_xml` | RubyGems | All versions | 0.5.2 |
| `multi_xml` | RubyGems | All versions | 0.5.2 |
| `ruby3.2-rubygem-multi_xml` | openSUSE:Tumbleweed | All versions | 0.6.0-1.23 |
| `rubygem-multi_xml` | openSUSE:Tumbleweed | All versions | 0.6.0-1.27 |
| `rubygem-multi_xml` | openSUSE:Tumbleweed | All versions | 0.6.0-1.29 |
| `rubygem-multi_xml` | openSUSE:Tumbleweed | All versions | 0.6.0-1.31 |

Products: Erik Michaels-Ober Multi Xml, Grape Project Grape.

## How do I fix CVE-2013-0175?

Upgrade multi_xml to 0.5.2 or later.

## Is CVE-2013-0175 being exploited?

There is no known exploitation of CVE-2013-0175 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0175 and fix it if it is affected.

What it is: CVE-2013-0175 is a high-severity unsafe deserialization vulnerability in n/a, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0175 in the wild and no public exploit code.

Affected packages and fixed versions:
- multi_xml (RubyGems): affected all versions; fixed in 0.5.2
- multi_xml (RubyGems): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0175/ (Markdown: https://insights.sbomify.com/CVE-2013-0175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0175
- OSV: https://osv.dev/vulnerability/CVE-2013-0175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0175/
Summaries are generated and may contain mistakes; the official description above is the record.
