{"answers":{"affected":"4 open source packages ship an affected version, including rack. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-0183 in the wild and no public exploit code.","fix":"Upgrade rack to a fixed version for your release line: 1.3.8 or 1.4.3.","what":"CVE-2013-0183 is a medium-severity denial of service vulnerability in n/a, published on 1 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-0183 and fix it if it is affected.\n\nWhat it is: CVE-2013-0183 is a medium-severity denial of service vulnerability in n/a, published on 1 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-0183 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rack (RubyGems): affected from 1.3.0; fixed in 1.3.8\n- rack (RubyGems): affected from 1.3.0; fixed in 1.3.8\n- rack (RubyGems): affected from 1.4.0; fixed in 1.4.3\n- rack (RubyGems): affected from 1.4.0; fixed in 1.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-0183/ (Markdown: https://insights.sbomify.com/CVE-2013-0183/index.md)","id":"CVE-2013-0183","markdown":"https://insights.sbomify.com/CVE-2013-0183/index.md","name":"CVE-2013-0183","record":{"aliases":["DEBIAN-CVE-2013-0183","GHSA-3pxh-h8hw-mj8w","UBUNTU-CVE-2013-0183"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby web server library","requires_auth":"none","summary":"Remote attackers can cause denial of service via memory exhaustion in Rack multipart parser, affecting Ruby web applications.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"rack","vendor":"rack_project"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"multipart/parser.rb in Rack 1.3.x before 1.3.8 and 1.4.x before 1.4.3 allows remote attackers to cause a denial of service (memory consumption and out-of-memory error) via a long string in a Multipart HTTP packet.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Rack rubygems receiving excessively long lines triggers out-of-memory error","id":"CVE-2013-0183","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2013"},"n_packages":4,"n_references":10,"next":{"headline":"Rack vulnerable to Denial of Service","id":"CVE-2013-0184"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.8"],"introduced":["1.3.0"],"last_affected":[],"package":"rack","purl":null,"source":"GHSA-3pxh-h8hw-mj8w"},{"ecosystem":"RubyGems","fixed":["1.3.8"],"introduced":["1.3.0"],"last_affected":[],"package":"rack","purl":"pkg:gem/rack","source":"GHSA-3pxh-h8hw-mj8w"},{"ecosystem":"RubyGems","fixed":["1.4.3"],"introduced":["1.4.0"],"last_affected":[],"package":"rack","purl":null,"source":"GHSA-3pxh-h8hw-mj8w"},{"ecosystem":"RubyGems","fixed":["1.4.3"],"introduced":["1.4.0"],"last_affected":[],"package":"rack","purl":"pkg:gem/rack","source":"GHSA-3pxh-h8hw-mj8w"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2013-0182"},"products":["n/a"],"published":"2013-03-01","related":[{"cvss_score":7.5,"headline":"Rack vulnerable to Denial of Service","id":"CVE-2018-16470","kev_date_added":null,"published":"2018-11-13"},{"cvss_score":5.1,"headline":"Rack arbitrary code execution via timing attack","id":"CVE-2013-0263","kev_date_added":null,"published":"2013-02-08"},{"cvss_score":5,"headline":"Rack Gem Subject to Denial of Service via Hash Collisions","id":"CVE-2011-5036","kev_date_added":null,"published":"2011-12-30"},{"cvss_score":4.3,"headline":"Rack vulnerable to REDoS","id":"CVE-2012-6109","kev_date_added":null,"published":"2013-03-01"},{"cvss_score":4.3,"headline":"Rack vulnerable to Denial of Service","id":"CVE-2013-0184","kev_date_added":null,"published":"2013-03-01"},{"cvss_score":4.3,"headline":"Rack Vulnerable to Path Traversal","id":"CVE-2013-0262","kev_date_added":null,"published":"2013-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via memory exhaustion in Rack multipart parser, affecting Ruby web applications.","url":"https://insights.sbomify.com/CVE-2013-0183/"}