CVE-2013-0184 Rack vulnerable to Denial of Service

Medium 4.3 Published Updated

Remote attackers can cause a denial of service in Rack applications by exploiting unspecified vectors related to symbolized arbitrary strings.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-0184?

CVE-2013-0184 is a medium-severity denial of service vulnerability in n/a, published on 1 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Which versions are affected by CVE-2013-0184?

8 open source packages ship an affected version, including rack. It affects 1 product.

PackageAffectedFixed in
rack RubyGemsFrom 1.1.01.1.5
rack RubyGemsFrom 1.1.01.1.5
rack RubyGemsFrom 1.2.01.2.7
rack RubyGemsFrom 1.2.01.2.7
rack RubyGemsFrom 1.3.01.3.9
rack RubyGemsFrom 1.3.01.3.9
2 more packages
rack RubyGemsFrom 1.4.01.4.4
rack RubyGemsFrom 1.4.01.4.4

Products include Rack Project Rack.

How do I fix CVE-2013-0184?

Upgrade rack to a fixed version for your release line: 1.1.5, 1.2.7, 1.3.9 or 1.4.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2013-0184 being exploited?

There is no known exploitation of CVE-2013-0184 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2013-0184, GHSA-v882-ccj6-jc48, UBUNTU-CVE-2013-0184.

Is CVE-2013-0184 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free