CVE-2013-0233 Devise does not properly perform type conversion when performing database queries
Remote attackers can bypass security checks and reset arbitrary account passwords due to improper type conversion in database queries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-0233?
CVE-2013-0233 is a medium-severity authentication bypass vulnerability in Opensuse Opensuse, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which might allow remote attackers to cause incorrect results to be returned and bypass security checks via unknown vectors, as demonstrated by resetting passwords of arbitrary accounts.
Weakness: CWE-399
Which versions are affected by CVE-2013-0233?
8 open source packages ship an affected version, including devise. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
devise RubyGems | From 1.5.0 | 1.5.4 |
devise RubyGems | From 1.5.0 | 1.5.4 |
devise RubyGems | From 2.0.0 | 2.0.5 |
devise RubyGems | From 2.0.0 | 2.0.5 |
devise RubyGems | From 2.1.0 | 2.1.3 |
devise RubyGems | From 2.1.0 | 2.1.3 |
2 more packages
devise RubyGems | From 2.2.0 | 2.2.3 |
devise RubyGems | From 2.2.0 | 2.2.3 |
Products include Opensuse Opensuse, Plataformatec Devise.
How do I fix CVE-2013-0233?
Upgrade devise to a fixed version for your release line: 1.5.4, 2.0.5, 2.1.3 or 2.2.3.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2013-0233 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-0233 exists.
Public exploit code: 1 Metasploit module.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as DEBIAN-CVE-2013-0233, GHSA-jxhw-mg8m-2pj8.