{"answers":{"affected":"8 open source packages ship an affected version, including devise. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-0233 exists.","fix":"Upgrade devise to a fixed version for your release line: 1.5.4, 2.0.5, 2.1.3 or 2.2.3.","what":"CVE-2013-0233 is a medium-severity authentication bypass vulnerability in Opensuse Opensuse, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-0233 and fix it if it is affected.\n\nWhat it is: CVE-2013-0233 is a medium-severity authentication bypass vulnerability in Opensuse Opensuse, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-0233 exists.\n\nAffected packages and fixed versions:\n- devise (RubyGems): affected from 1.5.0; fixed in 1.5.4\n- devise (RubyGems): affected from 1.5.0; fixed in 1.5.4\n- devise (RubyGems): affected from 2.0.0; fixed in 2.0.5\n- devise (RubyGems): affected from 2.0.0; fixed in 2.0.5\n- devise (RubyGems): affected from 2.1.0; fixed in 2.1.3\n- devise (RubyGems): affected from 2.1.0; fixed in 2.1.3\n- devise (RubyGems): affected from 2.2.0; fixed in 2.2.3\n- devise (RubyGems): affected from 2.2.0; fixed in 2.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-0233/ (Markdown: https://insights.sbomify.com/CVE-2013-0233/index.md)","id":"CVE-2013-0233","markdown":"https://insights.sbomify.com/CVE-2013-0233/index.md","name":"CVE-2013-0233","record":{"aliases":["DEBIAN-CVE-2013-0233","GHSA-jxhw-mg8m-2pj8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby authentication library","requires_auth":"none","summary":"Remote attackers can bypass security checks and reset arbitrary account passwords due to improper type conversion in database queries.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"devise","vendor":"plataformatec"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which might allow remote attackers to cause incorrect results to be returned and bypass security checks via unknown vectors, as demonstrated by resetting passwords of arbitrary accounts.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":"2013-01-28","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2013-01-28","kind":"metasploit","ref":"auxiliary/admin/http/rails_devise_pass_reset","stars":null,"title":"Ruby on Rails Devise Authentication Password Reset"}],"tier":"weaponised"},"has_fix":true,"headline":"Devise does not properly perform type conversion when performing database queries","id":"CVE-2013-0233","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"auth_bypass","year":"2013"},"n_packages":8,"n_references":7,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-0234"},"packages":[{"ecosystem":"RubyGems","fixed":["1.5.4"],"introduced":["1.5.0"],"last_affected":[],"package":"devise","purl":null,"source":"GHSA-jxhw-mg8m-2pj8"},{"ecosystem":"RubyGems","fixed":["1.5.4"],"introduced":["1.5.0"],"last_affected":[],"package":"devise","purl":"pkg:gem/devise","source":"GHSA-jxhw-mg8m-2pj8"},{"ecosystem":"RubyGems","fixed":["2.0.5"],"introduced":["2.0.0"],"last_affected":[],"package":"devise","purl":null,"source":"GHSA-jxhw-mg8m-2pj8"},{"ecosystem":"RubyGems","fixed":["2.0.5"],"introduced":["2.0.0"],"last_affected":[],"package":"devise","purl":"pkg:gem/devise","source":"GHSA-jxhw-mg8m-2pj8"},{"ecosystem":"RubyGems","fixed":["2.1.3"],"introduced":["2.1.0"],"last_affected":[],"package":"devise","purl":null,"source":"GHSA-jxhw-mg8m-2pj8"},{"ecosystem":"RubyGems","fixed":["2.1.3"],"introduced":["2.1.0"],"last_affected":[],"package":"devise","purl":"pkg:gem/devise","source":"GHSA-jxhw-mg8m-2pj8"},{"ecosystem":"RubyGems","fixed":["2.2.3"],"introduced":["2.2.0"],"last_affected":[],"package":"devise","purl":null,"source":"GHSA-jxhw-mg8m-2pj8"},{"ecosystem":"RubyGems","fixed":["2.2.3"],"introduced":["2.2.0"],"last_affected":[],"package":"devise","purl":"pkg:gem/devise","source":"GHSA-jxhw-mg8m-2pj8"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2013-0232"},"products":["n/a"],"published":"2013-04-25","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Remote attackers can bypass security checks and reset arbitrary account passwords due to improper type conversion in database queries.","url":"https://insights.sbomify.com/CVE-2013-0233/"}