# CVE-2013-0233: Devise does not properly perform type conversion when performing database queries

> Remote attackers can bypass security checks and reset arbitrary account passwords due to improper type conversion in database queries.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2013
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2013-0233, GHSA-jxhw-mg8m-2pj8

## What is CVE-2013-0233?

CVE-2013-0233 is a medium-severity authentication bypass vulnerability in Opensuse Opensuse, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which might allow remote attackers to cause incorrect results to be returned and bypass security checks via unknown vectors, as demonstrated by resetting passwords of arbitrary accounts.

Weakness: CWE-399

## Which versions are affected by CVE-2013-0233?

8 open source packages ship an affected version, including devise. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devise` | RubyGems | From 1.5.0 | 1.5.4 |
| `devise` | RubyGems | From 1.5.0 | 1.5.4 |
| `devise` | RubyGems | From 2.0.0 | 2.0.5 |
| `devise` | RubyGems | From 2.0.0 | 2.0.5 |
| `devise` | RubyGems | From 2.1.0 | 2.1.3 |
| `devise` | RubyGems | From 2.1.0 | 2.1.3 |
| `devise` | RubyGems | From 2.2.0 | 2.2.3 |
| `devise` | RubyGems | From 2.2.0 | 2.2.3 |

Products: Opensuse Opensuse, Plataformatec Devise.

## How do I fix CVE-2013-0233?

Upgrade devise to a fixed version for your release line: 1.5.4, 2.0.5, 2.1.3 or 2.2.3.

## Is CVE-2013-0233 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-0233 exists.

Public exploit code:

- Ruby on Rails Devise Authentication Password Reset (metasploit)

## Other vulnerabilities in Opensuse Opensuse

- [CVE-2015-5957](https://insights.sbomify.com/CVE-2015-5957/): Memory corruption in n/a (critical 10.0)
- [CVE-2015-0491](https://insights.sbomify.com/CVE-2015-0491/): Memory corruption in n/a (critical 10.0)
- [CVE-2008-2388](https://insights.sbomify.com/CVE-2008-2388/): Integer overflow in n/a (critical 10.0)
- [CVE-2010-1866](https://insights.sbomify.com/CVE-2010-1866/): Integer overflow in n/a (critical 9.8)
- [CVE-2015-0492](https://insights.sbomify.com/CVE-2015-0492/): Other in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0233 and fix it if it is affected.

What it is: CVE-2013-0233 is a medium-severity authentication bypass vulnerability in Opensuse Opensuse, published on 25 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-0233 exists.

Affected packages and fixed versions:
- devise (RubyGems): affected from 1.5.0; fixed in 1.5.4
- devise (RubyGems): affected from 1.5.0; fixed in 1.5.4
- devise (RubyGems): affected from 2.0.0; fixed in 2.0.5
- devise (RubyGems): affected from 2.0.0; fixed in 2.0.5
- devise (RubyGems): affected from 2.1.0; fixed in 2.1.3
- devise (RubyGems): affected from 2.1.0; fixed in 2.1.3
- devise (RubyGems): affected from 2.2.0; fixed in 2.2.3
- devise (RubyGems): affected from 2.2.0; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0233/ (Markdown: https://insights.sbomify.com/CVE-2013-0233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0233
- OSV: https://osv.dev/vulnerability/CVE-2013-0233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0233/
Summaries are generated and may contain mistakes; the official description above is the record.
