# CVE-2013-0239: Improper Authentication in Apache CXF

> Remote attackers can bypass authentication in Apache CXF by sending a SOAP request with a UsernameToken lacking a password when plaintext WS-SecurityPolicy is enabled.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p5c5-6564-vvr8

## What is CVE-2013-0239?

CVE-2013-0239 is a medium-severity authentication bypass vulnerability in Apache Cxf, published on 12 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache CXF before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3, when the plaintext UsernameToken WS-SecurityPolicy is enabled, allows remote attackers to bypass authentication via a security header of a SOAP request containing a UsernameToken element that lacks a password child element.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2013-0239?

6 open source packages ship an affected version, including org.apache.cxf:cxf-rt-frontend-jaxrs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | All versions | 2.5.9 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | All versions | 2.5.9 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.6.0 | 2.6.6 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.6.0 | 2.6.6 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.7.0 | 2.7.3 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.7.0 | 2.7.3 |

Products: Apache Cxf.

## How do I fix CVE-2013-0239?

Upgrade org.apache.cxf:cxf-rt-frontend-jaxrs to a fixed version for your release line: 2.5.9, 2.6.6 or 2.7.3.

## Is CVE-2013-0239 being exploited?

There is no known exploitation of CVE-2013-0239 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cxf

- [CVE-2012-2379](https://insights.sbomify.com/CVE-2012-2379/): XML Signature/Encryption Not Validated in Apache CXF (critical 10.0)
- [CVE-2026-66909](https://insights.sbomify.com/CVE-2026-66909/): Apache CXF: Unsafe deserialization of inbound JMS ObjectMessage (critical 9.8)
- [CVE-2026-68079](https://insights.sbomify.com/CVE-2026-68079/): Apache CXF: DefaultEncryptingCodeDataProvider allows unlimited authorization code replay (critical 9.8)
- [CVE-2026-50628](https://insights.sbomify.com/CVE-2026-50628/): Apache CXF: OAuth2: Inverted IP Binding Check Defeats Security Control (critical 9.8)
- [CVE-2025-48913](https://insights.sbomify.com/CVE-2025-48913/): Apache CXF: Untrusted JMS configuration can lead to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0239 and fix it if it is affected.

What it is: CVE-2013-0239 is a medium-severity authentication bypass vulnerability in Apache Cxf, published on 12 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0239 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected all versions; fixed in 2.5.9
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected all versions; fixed in 2.5.9
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.6.0; fixed in 2.6.6
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.6.0; fixed in 2.6.6
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.7.0; fixed in 2.7.3
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.7.0; fixed in 2.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0239/ (Markdown: https://insights.sbomify.com/CVE-2013-0239/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0239
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0239
- OSV: https://osv.dev/vulnerability/CVE-2013-0239

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0239/
Summaries are generated and may contain mistakes; the official description above is the record.
