# CVE-2013-0243: Security feature bypass in haskell-tls-extra

> Attackers can perform Man-in-the-Middle attacks on TLS connections due to improper validation of Basic Constraints attributes in the Haskell TLS library.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4q83-8359-v5v3, HSEC-2023-0005

## What is CVE-2013-0243?

CVE-2013-0243 is a high-severity vulnerability in haskell-tls-extra, published on 5 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

haskell-tls-extra before 0.6.1 has Basic Constraints attribute vulnerability may lead to Man in the Middle attacks on TLS connections

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-0243?

1 open source package ship an affected version, including tls-extra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tls-extra` | Hackage | From 0.1.0 | 0.4.6.1 |

Products: Haskell Hs-Tls.

## How do I fix CVE-2013-0243?

Upgrade tls-extra to 0.4.6.1 or later.

## Is CVE-2013-0243 being exploited?

There is no known exploitation of CVE-2013-0243 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0243 and fix it if it is affected.

What it is: CVE-2013-0243 is a high-severity vulnerability in haskell-tls-extra, published on 5 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0243 in the wild and no public exploit code.

Affected packages and fixed versions:
- tls-extra (Hackage): affected from 0.1.0; fixed in 0.4.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0243/ (Markdown: https://insights.sbomify.com/CVE-2013-0243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0243
- OSV: https://osv.dev/vulnerability/CVE-2013-0243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0243/
Summaries are generated and may contain mistakes; the official description above is the record.
