# CVE-2013-0256: RDoc contains XSS vulnerability

> Remote attackers can execute cross-site scripting attacks via crafted URLs in RDoc generated documents, affecting Ruby developers and users.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v2r9-c84j-v7xm, RHSA-2013:0728

## What is CVE-2013-0256?

CVE-2013-0256 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 1 Mar 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

darkfish.js in RDoc 2.3.0 through 3.12 and 4.x before 4.0.0.preview2.1, as used in Ruby, does not properly generate documents, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted URL.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-0256?

2 open source packages ship an affected version, including rdoc. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rdoc` | RubyGems | From 2.3.0 | 3.12.1 |
| `rdoc` | RubyGems | From 2.3.0 | 3.12.1 |
| `ruby193-rubygem-activesupport` | Red Hat:openshift:1::el6 | All versions | 1:3.2.8-4.el6 |
| `ruby193-rubygem-bcrypt-ruby` | Red Hat:openshift:1::el6 | All versions | 0:3.0.1-7.el6 |
| `ruby193-rubygem-bcrypt-ruby-debuginfo` | Red Hat:openshift:1::el6 | All versions | 0:3.0.1-7.el6 |
| `ruby193-rubygem-bson` | Red Hat:openshift:1::el6 | All versions | 0:1.5.2-6.el6op |
| `ruby193-rubygem-chunky_png` | Red Hat:openshift:1::el6 | All versions | 0:1.2.6-3.el6op |
| `ruby193-rubygem-ci_reporter` | Red Hat:openshift:1::el6 | All versions | 0:1.7.2-4.el6op |
| `ruby193-rubygem-compass` | Red Hat:openshift:1::el6 | All versions | 0:0.12.2-4.el6op |
| `ruby193-rubygem-fastthread` | Red Hat:openshift:1::el6 | All versions | 0:1.0.7-7.el6op |
| `ruby193-rubygem-fastthread-debuginfo` | Red Hat:openshift:1::el6 | All versions | 0:1.0.7-7.el6op |
| `ruby193-rubygem-haml` | Red Hat:openshift:1::el6 | All versions | 0:3.1.7-3.el6op |
| `ruby193-rubygem-http_connection` | Red Hat:openshift:1::el6 | All versions | 0:1.4.1-7.el6 |
| `ruby193-rubygem-rack` | Red Hat:openshift:1::el6 | All versions | 1:1.4.1-5.el6 |
| `ruby193-rubygem-rack-test` | Red Hat:openshift:1::el6 | All versions | 0:0.6.1-3.el6 |
| `ruby193-rubygem-rspec` | Red Hat:openshift:1::el6 | All versions | 0:2.11.0-2.el6 |
| `ruby193-rubygem-treetop` | Red Hat:openshift:1::el6 | All versions | 0:1.4.10-6.el6 |
| `ruby193-rubygem-xml-simple` | Red Hat:openshift:1::el6 | All versions | 0:1.0.12-10.el6op |

Products: Canonical Ubuntu Linux, Ruby-Lang Rdoc, Ruby-Lang Ruby.

## How do I fix CVE-2013-0256?

Upgrade rdoc to 3.12.1 or later.

## Is CVE-2013-0256 being exploited?

There is no known exploitation of CVE-2013-0256 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0256 and fix it if it is affected.

What it is: CVE-2013-0256 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 1 Mar 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-0256 in the wild and no public exploit code.

Affected packages and fixed versions:
- rdoc (RubyGems): affected from 2.3.0; fixed in 3.12.1
- rdoc (RubyGems): affected from 2.3.0; fixed in 3.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0256/ (Markdown: https://insights.sbomify.com/CVE-2013-0256/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0256
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0256
- OSV: https://osv.dev/vulnerability/CVE-2013-0256

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0256/
Summaries are generated and may contain mistakes; the official description above is the record.
