# CVE-2013-0262: Rack Vulnerable to Path Traversal

> Attackers can read arbitrary files outside the intended root directory via crafted PATH_INFO in Rack::File, exposing sensitive data.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-0262, GHSA-85r7-w5mv-c849, UBUNTU-CVE-2013-0262

## What is CVE-2013-0262?

CVE-2013-0262 is a medium-severity path traversal vulnerability in n/a, published on 8 Feb 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rack/file.rb (Rack::File) in Rack 1.5.x before 1.5.2 and 1.4.x before 1.4.5 allows attackers to access arbitrary files outside the intended root directory via a crafted PATH_INFO environment variable, probably a directory traversal vulnerability that is remotely exploitable, aka "symlink path traversals."

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2013-0262?

4 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | From 1.4.0 | 1.4.5 |
| `rack` | RubyGems | From 1.4.0 | 1.4.5 |
| `rack` | RubyGems | From 1.5.0 | 1.5.2 |
| `rack` | RubyGems | From 1.5.0 | 1.5.2 |

Products: Rack Project Rack.

## How do I fix CVE-2013-0262?

Upgrade rack to a fixed version for your release line: 1.4.5 or 1.5.2.

## Is CVE-2013-0262 being exploited?

There is no known exploitation of CVE-2013-0262 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-16470](https://insights.sbomify.com/CVE-2018-16470/): Rack vulnerable to Denial of Service (high 7.5)
- [CVE-2013-0263](https://insights.sbomify.com/CVE-2013-0263/): Rack arbitrary code execution via timing attack (medium 5.1)
- [CVE-2013-0183](https://insights.sbomify.com/CVE-2013-0183/): Rack rubygems receiving excessively long lines triggers out-of-memory error (medium 5.0)
- [CVE-2011-5036](https://insights.sbomify.com/CVE-2011-5036/): Rack Gem Subject to Denial of Service via Hash Collisions (medium 5.0)
- [CVE-2012-6109](https://insights.sbomify.com/CVE-2012-6109/): Rack vulnerable to REDoS (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0262 and fix it if it is affected.

What it is: CVE-2013-0262 is a medium-severity path traversal vulnerability in n/a, published on 8 Feb 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0262 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected from 1.4.0; fixed in 1.4.5
- rack (RubyGems): affected from 1.4.0; fixed in 1.4.5
- rack (RubyGems): affected from 1.5.0; fixed in 1.5.2
- rack (RubyGems): affected from 1.5.0; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0262/ (Markdown: https://insights.sbomify.com/CVE-2013-0262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0262
- OSV: https://osv.dev/vulnerability/CVE-2013-0262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0262/
Summaries are generated and may contain mistakes; the official description above is the record.
