CVE-2013-0269 JSON gem has Improper Input Validation vulnerability
Remote attackers can cause denial of service or bypass mass assignment protection in Ruby applications via crafted JSON documents.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-0269?
CVE-2013-0269 is a high-severity denial of service vulnerability in n/a, published on 13 Feb 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka "Unsafe Object Creation Vulnerability."
Weakness: CWE-20
Which versions are affected by CVE-2013-0269?
6 open source packages ship an affected version, including json. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
json RubyGems | All versions | 1.5.5 |
json RubyGems | All versions | 1.5.5 |
json RubyGems | From 1.6.0 | 1.6.8 |
json RubyGems | From 1.6.0 | 1.6.8 |
json RubyGems | From 1.7.0 | 1.7.7 |
json RubyGems | From 1.7.0 | 1.7.7 |
Products include Rubygems Json Gem.
How do I fix CVE-2013-0269?
Upgrade json to a fixed version for your release line: 1.5.5, 1.6.8 or 1.7.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-0269 being exploited?
There is no known exploitation of CVE-2013-0269 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as DEBIAN-CVE-2013-0269, DLA-215-1, GHSA-x457-cw4h-hq5f.