CVE-2013-0277 Active Record contains deserialization of arbitrary YAML

Critical 10.0 Published Updated

Remote attackers can execute arbitrary code or cause denial of service via crafted serialized YAML attributes in Ruby on Rails ActiveRecord.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-0277?

CVE-2013-0277 is a critical unsafe deserialization vulnerability in Rubyonrails Rails, published on 13 Feb 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ActiveRecord in Ruby on Rails before 2.3.17 and 3.x before 3.1.0 allows remote attackers to cause a denial of service or execute arbitrary code via crafted serialized attributes that cause the +serialize+ helper to deserialize arbitrary YAML.

Which versions are affected by CVE-2013-0277?

4 open source packages ship an affected version, including activerecord. It affects 2 products.

PackageAffectedFixed in
activerecord RubyGemsAll versions2.3.17
activerecord RubyGemsAll versions2.3.17
activerecord RubyGemsFrom 3.0.03.1.0
activerecord RubyGemsFrom 3.0.03.1.0

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2013-0277?

Upgrade activerecord to a fixed version for your release line: 2.3.17 or 3.1.0.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2013-0277 being exploited?

There is no known exploitation of CVE-2013-0277 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2013-0277, GHSA-fhj9-cjjh-27vm.

Is CVE-2013-0277 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free