# CVE-2013-0277: Active Record contains deserialization of arbitrary YAML

> Remote attackers can execute arbitrary code or cause denial of service via crafted serialized YAML attributes in Ruby on Rails ActiveRecord.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-0277, GHSA-fhj9-cjjh-27vm

## What is CVE-2013-0277?

CVE-2013-0277 is a critical unsafe deserialization vulnerability in Rubyonrails Rails, published on 13 Feb 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ActiveRecord in Ruby on Rails before 2.3.17 and 3.x before 3.1.0 allows remote attackers to cause a denial of service or execute arbitrary code via crafted serialized attributes that cause the +serialize+ helper to deserialize arbitrary YAML.

## Which versions are affected by CVE-2013-0277?

4 open source packages ship an affected version, including activerecord. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | All versions | 2.3.17 |
| `activerecord` | RubyGems | All versions | 2.3.17 |
| `activerecord` | RubyGems | From 3.0.0 | 3.1.0 |
| `activerecord` | RubyGems | From 3.0.0 | 3.1.0 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2013-0277?

Upgrade activerecord to a fixed version for your release line: 2.3.17 or 3.1.0.

## Is CVE-2013-0277 being exploited?

There is no known exploitation of CVE-2013-0277 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)
- [CVE-2023-22792](https://insights.sbomify.com/CVE-2023-22792/): ReDoS based DoS vulnerability in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0277 and fix it if it is affected.

What it is: CVE-2013-0277 is a critical unsafe deserialization vulnerability in Rubyonrails Rails, published on 13 Feb 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0277 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected all versions; fixed in 2.3.17
- activerecord (RubyGems): affected all versions; fixed in 2.3.17
- activerecord (RubyGems): affected from 3.0.0; fixed in 3.1.0
- activerecord (RubyGems): affected from 3.0.0; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0277/ (Markdown: https://insights.sbomify.com/CVE-2013-0277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0277
- OSV: https://osv.dev/vulnerability/CVE-2013-0277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0277/
Summaries are generated and may contain mistakes; the official description above is the record.
