# CVE-2013-0282: OpenStack Keystone allows context-dependent attackers to bypass access restrictions

> Attackers can bypass access restrictions in OpenStack Keystone EC2-style authentication by exploiting missing enabled checks for users, tenants, or domains.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-0282, GHSA-8833-qrvm-wc3h, PYSEC-2026-652

## What is CVE-2013-0282?

CVE-2013-0282 is a medium-severity authentication bypass vulnerability in n/a, published on 12 Apr 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Keystone Grizzly before 2013.1, Folsom 2012.1.3 and earlier, and Essex does not properly check if the (1) user, (2) tenant, or (3) domain is enabled when using EC2-style authentication, which allows context-dependent attackers to bypass access restrictions.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2013-0282?

3 open source packages ship an affected version, including keystone and Keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `Keystone` | PyPI | All versions | 8.0.0a0 |

Products: Openstack Keystone.

## How do I fix CVE-2013-0282?

Upgrade keystone to 8.0.0a0 or later.

## Is CVE-2013-0282 being exploited?

There is no known exploitation of CVE-2013-0282 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0282 and fix it if it is affected.

What it is: CVE-2013-0282 is a medium-severity authentication bypass vulnerability in n/a, published on 12 Apr 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0282 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- Keystone (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0282/ (Markdown: https://insights.sbomify.com/CVE-2013-0282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0282
- OSV: https://osv.dev/vulnerability/CVE-2013-0282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0282/
Summaries are generated and may contain mistakes; the official description above is the record.
