CVE-2013-0305 Django Data leakage via admin history log
Remote authenticated administrators can access sensitive object history information in the Django admin interface due to missing permission checks.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-0305?
CVE-2013-0305 is a medium-severity missing authorization vulnerability in Canonical Ubuntu Linux, published on 2 May 2013. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
The administrative interface for Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 does not check permissions for the history view, which allows remote authenticated administrators to obtain sensitive object history information.
Weakness: CWE-200
Which versions are affected by CVE-2013-0305?
5 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.3 | 1.3.6, 1.4.4 |
django PyPI | From 1.3 | 1.3.6 |
django PyPI | From 1.4 | 1.4.4 |
Django PyPI | From 1.3 | 1.3.6 |
Django PyPI | From 1.4 | 1.4.4 |
Products include Canonical Ubuntu Linux, Djangoproject Django.
How do I fix CVE-2013-0305?
Upgrade django to a fixed version for your release line: 1.3.6 or 1.4.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2013-0305 being exploited?
There is no known exploitation of CVE-2013-0305 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2013-0305, GHSA-r7w6-p47g-vj53, PYSEC-2013-16.