CVE-2013-0306 Django is vulnerable to Denial of Service attack in formset
Remote attackers can cause denial of service by modifying the max_num parameter in Django formsets, leading to excessive memory consumption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-0306?
CVE-2013-0306 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 2 May 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
Weakness: CWE-189
Which versions are affected by CVE-2013-0306?
5 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.3 | 1.3.6, 1.4.4 |
django PyPI | From 1.3 | 1.3.6 |
django PyPI | From 1.4 | 1.4.4 |
Django PyPI | From 1.3 | 1.3.6 |
Django PyPI | From 1.4 | 1.4.4 |
Products include Canonical Ubuntu Linux, Djangoproject Django.
How do I fix CVE-2013-0306?
Upgrade django to a fixed version for your release line: 1.3.6 or 1.4.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-0306 being exploited?
There is no known exploitation of CVE-2013-0306 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2013-0306, GHSA-g8xg-jgj6-49r3, PYSEC-2013-17.