{"answers":{"affected":"5 open source packages ship an affected version, including django and Django. It affects 2 products.","exploited":"There is no known exploitation of CVE-2013-0306 in the wild and no public exploit code.","fix":"Upgrade django to a fixed version for your release line: 1.3.6 or 1.4.4.","what":"CVE-2013-0306 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 2 May 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-0306 and fix it if it is affected.\n\nWhat it is: CVE-2013-0306 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 2 May 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-0306 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- django (PyPI): affected from 1.3; fixed in 1.3.6, 1.4.4\n- django (PyPI): affected from 1.3; fixed in 1.3.6\n- django (PyPI): affected from 1.4; fixed in 1.4.4\n- Django (PyPI): affected from 1.3; fixed in 1.3.6\n- Django (PyPI): affected from 1.4; fixed in 1.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-0306/ (Markdown: https://insights.sbomify.com/CVE-2013-0306/index.md)","id":"CVE-2013-0306","markdown":"https://insights.sbomify.com/CVE-2013-0306/index.md","name":"CVE-2013-0306","record":{"aliases":["DEBIAN-CVE-2013-0306","GHSA-g8xg-jgj6-49r3","PYSEC-2013-17"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Django web framework","requires_auth":"none","summary":"Remote attackers can cause denial of service by modifying the max_num parameter in Django formsets, leading to excessive memory consumption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"django","vendor":"djangoproject"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-189","name":null}],"description":"The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Django is vulnerable to Denial of Service attack in formset","id":"CVE-2013-0306","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","djangoproject:django"],"type":"denial_of_service","year":"2013"},"n_packages":5,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-0307"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.6"],"introduced":["1.3"],"last_affected":[],"package":"Django","purl":null,"source":"GHSA-g8xg-jgj6-49r3"},{"ecosystem":"PyPI","fixed":["1.4.4"],"introduced":["1.4"],"last_affected":[],"package":"Django","purl":null,"source":"GHSA-g8xg-jgj6-49r3"},{"ecosystem":"PyPI","fixed":["1.3.6","1.4.4"],"introduced":["1.3","1.4"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"PYSEC-2013-17"},{"ecosystem":"PyPI","fixed":["1.3.6"],"introduced":["1.3"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"GHSA-g8xg-jgj6-49r3"},{"ecosystem":"PyPI","fixed":["1.4.4"],"introduced":["1.4"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"GHSA-g8xg-jgj6-49r3"}],"prev":{"headline":"Django Data leakage via admin history log","id":"CVE-2013-0305"},"products":["n/a"],"published":"2013-05-02","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service by modifying the max_num parameter in Django formsets, leading to excessive memory consumption.","url":"https://insights.sbomify.com/CVE-2013-0306/"}