CVE-2013-0327 Jenkins Cross-Site Request Forgery vulnerability

Medium 6.8 Published Updated

Remote attackers can hijack user authentication in Jenkins via CSRF, requiring user interaction to execute malicious actions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2013-0327?

CVE-2013-0327 is a medium-severity vulnerability in Jenkins Jenkins, published on 19 Mar 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cross-site request forgery (CSRF) vulnerability in Jenkins master in Jenkins before 1.502 and LTS before 1.480.3 allows remote attackers to hijack the authentication of users via unknown vectors.

Weakness: CWE-352

Which versions are affected by CVE-2013-0327?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.480.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.480.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.4811.502
org.jenkins-ci.main:jenkins-core MavenFrom 1.4811.502

Products include Jenkins Jenkins.

How do I fix CVE-2013-0327?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.480.3 or 1.502.

Is CVE-2013-0327 being exploited?

There is no known exploitation of CVE-2013-0327 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-rqhg-cxfr-8xqw.

Is CVE-2013-0327 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free