CVE-2013-0331 Jenkins Vulnerable to Denial of Service (DoS) via Crafted Payload

Medium 4.0 Published Updated

Authenticated users with write access can cause a denial of service in Jenkins via a crafted payload.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-0331?

CVE-2013-0331 is a medium-severity denial of service vulnerability in Jenkins Jenkins, published on 19 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before 1.502 and LTS before 1.480.3 allows remote authenticated users with write access to cause a denial of service via a crafted payload.

Weakness: CWE-20

Which versions are affected by CVE-2013-0331?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.480.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.480.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.4811.502
org.jenkins-ci.main:jenkins-core MavenFrom 1.4811.502

Products include Jenkins Jenkins.

How do I fix CVE-2013-0331?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.480.3 or 1.502.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2013-0331 being exploited?

There is no known exploitation of CVE-2013-0331 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-5c56-g5cq-4gj9.

Is CVE-2013-0331 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free