# CVE-2013-0331: Jenkins Vulnerable to Denial of Service (DoS) via Crafted Payload

> Authenticated users with write access can cause a denial of service in Jenkins via a crafted payload.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5c56-g5cq-4gj9

## What is CVE-2013-0331?

CVE-2013-0331 is a medium-severity denial of service vulnerability in Jenkins Jenkins, published on 19 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins before 1.502 and LTS before 1.480.3 allows remote authenticated users with write access to cause a denial of service via a crafted payload.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-0331?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.480.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.480.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.481 | 1.502 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.481 | 1.502 |

Products: Jenkins Jenkins.

## How do I fix CVE-2013-0331?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.480.3 or 1.502.

## Is CVE-2013-0331 being exploited?

There is no known exploitation of CVE-2013-0331 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0331 and fix it if it is affected.

What it is: CVE-2013-0331 is a medium-severity denial of service vulnerability in Jenkins Jenkins, published on 19 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0331 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.480.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.480.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.481; fixed in 1.502
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.481; fixed in 1.502

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0331/ (Markdown: https://insights.sbomify.com/CVE-2013-0331/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0331
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0331
- OSV: https://osv.dev/vulnerability/CVE-2013-0331

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0331/
Summaries are generated and may contain mistakes; the official description above is the record.
