# CVE-2013-0731: Missing authorization in n/a

> Remote attackers can modify plugin settings and inject scripts by exploiting missing authorization checks in the MailUp WordPress plugin.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j99w-349h-39gr

## What is CVE-2013-0731?

CVE-2013-0731 is a medium-severity missing authorization vulnerability in n/a, published on 22 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ajax.functions.php in the MailUp plugin before 1.3.3 for WordPress does not properly restrict access to unspecified Ajax functions, which allows remote attackers to modify plugin settings and conduct cross-site scripting (XSS) attacks by setting the wordpress_logged_in cookie.  NOTE: this is due to an incomplete fix for a similar issue that was fixed in 1.3.2.

Weakness: CWE-264

## Which versions are affected by CVE-2013-0731?

It affects 1 product.


Products: Mailup Wp-Mailup.

## How do I fix CVE-2013-0731?

No fix has been published for CVE-2013-0731 yet. Limit exposure of the affected software until one is available.

## Is CVE-2013-0731 being exploited?

There is no known exploitation of CVE-2013-0731 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-2640](https://insights.sbomify.com/CVE-2013-2640/): Missing authorization in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-0731 and fix it if it is affected.

What it is: CVE-2013-0731 is a medium-severity missing authorization vulnerability in n/a, published on 22 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-0731 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-0731/ (Markdown: https://insights.sbomify.com/CVE-2013-0731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-0731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-0731
- OSV: https://osv.dev/vulnerability/CVE-2013-0731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-0731/
Summaries are generated and may contain mistakes; the official description above is the record.
