# CVE-2013-10021: dd32 Debug Bar Plugin class-debug-bar-queries.php render cross site scripting

> A cross-site scripting vulnerability in the dd32 Debug Bar WordPress plugin allows remote attackers to inject malicious scripts via the query panel.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 Mar 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-2mv3-mwwf-9mrv

## What is CVE-2013-10021?

CVE-2013-10021 is a low-severity cross-site scripting vulnerability in dd32 Debug Bar Plugin, published on 11 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in dd32 Debug Bar Plugin up to 0.8 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function render of the file panels/class-debug-bar-queries.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.8.1 is able to address this issue. The patch is named 0842af8f8a556bc3e39b9ef758173b0a8a9ccbfc. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222739.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-10021?

It affects 1 product.


Products: Wordpress Debug Bar.

## How do I fix CVE-2013-10021?

No fix has been published for CVE-2013-10021 yet. Limit exposure of the affected software until one is available.

## Is CVE-2013-10021 being exploited?

There is no known exploitation of CVE-2013-10021 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-10021 and fix it if it is affected.

What it is: CVE-2013-10021 is a low-severity cross-site scripting vulnerability in dd32 Debug Bar Plugin, published on 11 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-10021 in the wild and no public exploit code.

Affected product: dd32 Debug Bar Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-10021/ (Markdown: https://insights.sbomify.com/CVE-2013-10021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-10021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-10021
- OSV: https://osv.dev/vulnerability/CVE-2013-10021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-10021/
Summaries are generated and may contain mistakes; the official description above is the record.
