{"answers":{"affected":"4 open source packages ship an affected version, including symfony/symfony and symfony/yaml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1348 in the wild and no public exploit code.","fix":"Upgrade symfony/symfony to 2.0.22 or later.","what":"CVE-2013-1348 is a high-severity code injection vulnerability in Sensiolabs Symfony, published on 2 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1348 and fix it if it is affected.\n\nWhat it is: CVE-2013-1348 is a high-severity code injection vulnerability in Sensiolabs Symfony, published on 2 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1348 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- symfony/symfony (Packagist): affected from 2.0.0; fixed in 2.0.22\n- symfony/symfony (Packagist): affected from 2.0.0; fixed in 2.0.22\n- symfony/yaml (Packagist): affected from 2.0.0; fixed in 2.0.22\n- symfony/yaml (Packagist): affected from 2.0.0; fixed in 2.0.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1348/ (Markdown: https://insights.sbomify.com/CVE-2013-1348/index.md)","id":"CVE-2013-1348","markdown":"https://insights.sbomify.com/CVE-2013-1348/index.md","name":"CVE-2013-1348","record":{"aliases":["GHSA-2r5h-6r7v-5m7c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony YAML parser","requires_auth":"none","summary":"Remote attackers can execute arbitrary PHP code via crafted YAML input in the Symfony library, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"symfony","vendor":"sensiolabs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The Yaml::parse function in Symfony 2.0.x before 2.0.22 remote attackers to execute arbitrary PHP code via a PHP file, a different vulnerability than CVE-2013-1397.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Symphony Vulnerable to PHP Code Injection via YAML Parsing","id":"CVE-2013-1348","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"sensiolabs:symfony","products":["sensiolabs:symfony"],"type":"code_injection","year":"2013"},"n_packages":4,"n_references":4,"next":{"headline":"Code injection in n/a","id":"CVE-2013-1349"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.22"],"introduced":["2.0.0"],"last_affected":[],"package":"symfony/symfony","purl":null,"source":"GHSA-2r5h-6r7v-5m7c"},{"ecosystem":"Packagist","fixed":["2.0.22"],"introduced":["2.0.0"],"last_affected":[],"package":"symfony/symfony","purl":"pkg:composer/symfony/symfony","source":"GHSA-2r5h-6r7v-5m7c"},{"ecosystem":"Packagist","fixed":["2.0.22"],"introduced":["2.0.0"],"last_affected":[],"package":"symfony/yaml","purl":null,"source":"GHSA-2r5h-6r7v-5m7c"},{"ecosystem":"Packagist","fixed":["2.0.22"],"introduced":["2.0.0"],"last_affected":[],"package":"symfony/yaml","purl":"pkg:composer/symfony/yaml","source":"GHSA-2r5h-6r7v-5m7c"}],"prev":{"headline":"Microsoft Internet Explorer Remote Code Execution","id":"CVE-2013-1347"},"products":["n/a"],"published":"2014-06-02","related":[{"cvss_score":9.8,"headline":"Improper Input Validation in Symfony","id":"CVE-2019-11325","kev_date_added":null,"published":"2019-11-21"},{"cvss_score":9.8,"headline":"Symfony Incorrect Access Control","id":"CVE-2017-11365","kev_date_added":null,"published":"2019-05-23"},{"cvss_score":9.8,"headline":"Invalid HTTP method overrides allow possible XSS or other attacks in Symfony","id":"CVE-2019-10913","kev_date_added":null,"published":"2019-05-16"},{"cvss_score":9.8,"headline":"Symfony Authentication Bypass","id":"CVE-2018-11407","kev_date_added":null,"published":"2018-06-13"},{"cvss_score":9.8,"headline":"Symfony Authentication Bypass","id":"CVE-2016-2403","kev_date_added":null,"published":"2017-02-07"},{"cvss_score":9.1,"headline":"Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator","id":"CVE-2026-45063","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":8.8,"headline":"Symfony: OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims","id":"CVE-2026-45069","kev_date_added":null,"published":"2026-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary PHP code via crafted YAML input in the Symfony library, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2013-1348/"}