# CVE-2013-1348: Symphony Vulnerable to PHP Code Injection via YAML Parsing

> Remote attackers can execute arbitrary PHP code via crafted YAML input in the Symfony library, requiring an upgrade to secure the application.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-2r5h-6r7v-5m7c

## What is CVE-2013-1348?

CVE-2013-1348 is a high-severity code injection vulnerability in Sensiolabs Symfony, published on 2 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Yaml::parse function in Symfony 2.0.x before 2.0.22 remote attackers to execute arbitrary PHP code via a PHP file, a different vulnerability than CVE-2013-1397.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2013-1348?

4 open source packages ship an affected version, including symfony/symfony and symfony/yaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/symfony` | Packagist | From 2.0.0 | 2.0.22 |
| `symfony/symfony` | Packagist | From 2.0.0 | 2.0.22 |
| `symfony/yaml` | Packagist | From 2.0.0 | 2.0.22 |
| `symfony/yaml` | Packagist | From 2.0.0 | 2.0.22 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2013-1348?

Upgrade symfony/symfony to 2.0.22 or later.

## Is CVE-2013-1348 being exploited?

There is no known exploitation of CVE-2013-1348 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1348 and fix it if it is affected.

What it is: CVE-2013-1348 is a high-severity code injection vulnerability in Sensiolabs Symfony, published on 2 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1348 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 2.0.22
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 2.0.22
- symfony/yaml (Packagist): affected from 2.0.0; fixed in 2.0.22
- symfony/yaml (Packagist): affected from 2.0.0; fixed in 2.0.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1348/ (Markdown: https://insights.sbomify.com/CVE-2013-1348/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1348
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1348
- OSV: https://osv.dev/vulnerability/CVE-2013-1348

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1348/
Summaries are generated and may contain mistakes; the official description above is the record.
