CVE-2013-1397 Symfony Arbitrary PHP code Execution
Remote attackers can execute arbitrary PHP code by sending malicious serialized objects to the Symfony YAML parser.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-1397?
CVE-2013-1397 is a high-severity unsafe deserialization vulnerability in Sensiolabs Symfony, published on 2 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to the (1) Yaml::parse or (2) Yaml\Parser::parse function, a different vulnerability than CVE-2013-1348.
Weakness: CWE-94
Which versions are affected by CVE-2013-1397?
12 open source packages ship an affected version, including symfony/symfony and symfony/yaml. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/symfony Packagist | From 2.0.0 | 2.0.22 |
symfony/symfony Packagist | From 2.0.0 | 2.0.22 |
symfony/symfony Packagist | From 2.1.0 | 2.1.7 |
symfony/symfony Packagist | From 2.1.0 | 2.1.7 |
symfony/symfony Packagist | From 2.2.0-BETA1 | 2.2.0-BETA2 |
symfony/symfony Packagist | From 2.2.0-BETA1 | 2.2.0-BETA2 |
6 more packages
symfony/yaml Packagist | From 2.0.0 | 2.0.22 |
symfony/yaml Packagist | From 2.0.0 | 2.0.22 |
symfony/yaml Packagist | From 2.1.0 | 2.1.7 |
symfony/yaml Packagist | From 2.1.0 | 2.1.7 |
symfony/yaml Packagist | From 2.2.0-BETA1 | 2.2.0-BETA2 |
symfony/yaml Packagist | From 2.2.0-BETA1 | 2.2.0-BETA2 |
Products include Sensiolabs Symfony.
How do I fix CVE-2013-1397?
Upgrade symfony/symfony to a fixed version for your release line: 2.0.22, 2.1.7 or 2.2.0-BETA2.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2013-1397 being exploited?
There is no known exploitation of CVE-2013-1397 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as GHSA-7w53-hfpw-rg3g.