# CVE-2013-1445: PyCrypto does not properly reseed PRNG before allowing access

> Attackers can obtain sensitive information by exploiting a race condition in the PRNG reseeding process during child process creation.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Not stated
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Oct 2013
- **Updated:** 16 Sep 2024
- **Also known as:** DSA-2781-1, GHSA-x377-f64p-hf5j, MGASA-2013-0319, PYSEC-2013-29

## What is CVE-2013-1445?

CVE-2013-1445 is a medium-severity vulnerability in n/a, published on 26 Oct 2013. 

### Official description

The Crypto.Random.atfork function in PyCrypto before 2.6.1 does not properly reseed the pseudo-random number generator (PRNG) before allowing a child process to access it, which makes it easier for context-dependent attackers to obtain sensitive information by leveraging a race condition in which a child process is created and accesses the PRNG within the same rate-limit period as another process.

Weakness: CWE-310

## Which versions are affected by CVE-2013-1445?

3 open source packages ship an affected version, including pycrypto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycrypto` | PyPI | All versions | 2.6.1 |
| `pycrypto` | PyPI | All versions | 2.6.1 |
| `pycrypto` | PyPI | All versions | 2.6.1 |

Products: Dlitz Pycrypto.

## How do I fix CVE-2013-1445?

Upgrade pycrypto to 2.6.1 or later.

## Is CVE-2013-1445 being exploited?

There is no known exploitation of CVE-2013-1445 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-7459](https://insights.sbomify.com/CVE-2013-7459/): Buffer Overflow in pycrypto (critical 9.8)
- [CVE-2012-2417](https://insights.sbomify.com/CVE-2012-2417/): PyCrypto makes Use of Insufficiently Random Values (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1445 and fix it if it is affected.

What it is: CVE-2013-1445 is a medium-severity vulnerability in n/a, published on 26 Oct 2013. 
Exploitation: There is no known exploitation of CVE-2013-1445 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycrypto (PyPI): affected all versions; fixed in 2.6.1
- pycrypto (PyPI): affected all versions; fixed in 2.6.1
- pycrypto (PyPI): affected all versions; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1445/ (Markdown: https://insights.sbomify.com/CVE-2013-1445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1445
- OSV: https://osv.dev/vulnerability/CVE-2013-1445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1445/
Summaries are generated and may contain mistakes; the official description above is the record.
