{"answers":{"affected":"2 open source packages ship an affected version, including pdfkit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1607 in the wild and no public exploit code.","fix":"Upgrade pdfkit to 0.5.3 or later.","what":"CVE-2013-1607 is a critical vulnerability in n/a, published on 11 Feb 2020."},"fix_prompt":"Check this codebase for CVE-2013-1607 and fix it if it is affected.\n\nWhat it is: CVE-2013-1607 is a critical vulnerability in n/a, published on 11 Feb 2020. \nExploitation: There is no known exploitation of CVE-2013-1607 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pdfkit (RubyGems): affected all versions; fixed in 0.5.3\n- pdfkit (RubyGems): affected all versions; fixed in 0.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1607/ (Markdown: https://insights.sbomify.com/CVE-2013-1607/index.md)","id":"CVE-2013-1607","markdown":"https://insights.sbomify.com/CVE-2013-1607/index.md","name":"CVE-2013-1607","record":{"aliases":["GHSA-39v7-xpq4-8884"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"pdfkit","vendor":"pdfkit_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PDFKit Improper Input Validation vulnerability","id":"CVE-2013-1607","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2013"},"n_packages":2,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2013-1608"},"packages":[{"ecosystem":"RubyGems","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"pdfkit","purl":null,"source":"GHSA-39v7-xpq4-8884"},{"ecosystem":"RubyGems","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"pdfkit","purl":"pkg:gem/pdfkit","source":"GHSA-39v7-xpq4-8884"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2013-1606"},"products":["n/a"],"published":"2020-02-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2013-1607/"}