# CVE-2013-1607: PDFKit Improper Input Validation vulnerability


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-39v7-xpq4-8884

## What is CVE-2013-1607?

CVE-2013-1607 is a critical vulnerability in n/a, published on 11 Feb 2020. 

### Official description

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-1607?

2 open source packages ship an affected version, including pdfkit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pdfkit` | RubyGems | All versions | 0.5.3 |
| `pdfkit` | RubyGems | All versions | 0.5.3 |

Products: Pdfkit Project Pdfkit.

## How do I fix CVE-2013-1607?

Upgrade pdfkit to 0.5.3 or later.

## Is CVE-2013-1607 being exploited?

There is no known exploitation of CVE-2013-1607 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1607 and fix it if it is affected.

What it is: CVE-2013-1607 is a critical vulnerability in n/a, published on 11 Feb 2020. 
Exploitation: There is no known exploitation of CVE-2013-1607 in the wild and no public exploit code.

Affected packages and fixed versions:
- pdfkit (RubyGems): affected all versions; fixed in 0.5.3
- pdfkit (RubyGems): affected all versions; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1607/ (Markdown: https://insights.sbomify.com/CVE-2013-1607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1607
- OSV: https://osv.dev/vulnerability/CVE-2013-1607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1607/
Summaries are generated and may contain mistakes; the official description above is the record.
