{"answers":{"affected":"3 open source packages ship an affected version, including pip. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1629 in the wild and no public exploit code.","fix":"Upgrade pip to 1.3 or later.","what":"CVE-2013-1629 is a medium-severity vulnerability in n/a, published on 6 Aug 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-1629 and fix it if it is affected.\n\nWhat it is: CVE-2013-1629 is a medium-severity vulnerability in n/a, published on 6 Aug 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-1629 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pip (PyPI): affected all versions; fixed in 1.3\n- pip (PyPI): affected all versions; fixed in 1.3\n- pip (PyPI): affected all versions; fixed in 1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1629/ (Markdown: https://insights.sbomify.com/CVE-2013-1629/index.md)","id":"CVE-2013-1629","markdown":"https://insights.sbomify.com/CVE-2013-1629/index.md","name":"CVE-2013-1629","record":{"aliases":["DEBIAN-CVE-2013-1629","GHSA-g3p5-fjj9-h8gj","PYSEC-2013-8"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python package installer","requires_auth":"none","summary":"Man-in-the-middle attackers can execute arbitrary code by intercepting unverified HTTP package downloads during pip install operations.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pip","vendor":"pypa"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a \"pip install\" operation.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in pip","id":"CVE-2013-1629","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2013"},"n_packages":3,"n_references":6,"next":{"headline":"pyshop vulnerable to man-in-the-middle attacks due to using HTTP to retrieve packages from the PyPI repository","id":"CVE-2013-1630"},"packages":[{"ecosystem":"PyPI","fixed":["1.3"],"introduced":["0"],"last_affected":[],"package":"pip","purl":null,"source":"GHSA-g3p5-fjj9-h8gj"},{"ecosystem":"PyPI","fixed":["1.3"],"introduced":["0"],"last_affected":[],"package":"pip","purl":"pkg:pypi/pip","source":"GHSA-g3p5-fjj9-h8gj"},{"ecosystem":"PyPI","fixed":["1.3"],"introduced":["0"],"last_affected":[],"package":"pip","purl":"pkg:pypi/pip","source":"PYSEC-2013-8"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2013-1628"},"products":["n/a"],"published":"2013-08-06","related":[{"cvss_score":7.8,"headline":"Supply chain in n/a","id":"CVE-2018-20225","kev_date_added":null,"published":"2020-05-08"},{"cvss_score":5.6,"headline":"pip absolute path traversal during download from malicious package indexes","id":"CVE-2026-13346","kev_date_added":null,"published":"2026-07-29"},{"cvss_score":5.5,"headline":"Mercurial configuration injectable in repo revision when installing via pip","id":"CVE-2023-5752","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":4.1,"headline":"pip can extract console_scripts and gui_scripts outside installation directory","id":"CVE-2026-8643","kev_date_added":null,"published":"2026-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can execute arbitrary code by intercepting unverified HTTP package downloads during pip install operations.","url":"https://insights.sbomify.com/CVE-2013-1629/"}