{"answers":{"affected":"3 open source packages ship an affected version, including pyshop. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1630 in the wild and no public exploit code.","fix":"Upgrade pyshop to 0.7.1 or later.","what":"CVE-2013-1630 is a medium-severity vulnerability in n/a, published on 6 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1630 and fix it if it is affected.\n\nWhat it is: CVE-2013-1630 is a medium-severity vulnerability in n/a, published on 6 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1630 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyshop (PyPI): affected all versions; fixed in 0.7.1\n- pyshop (PyPI): affected all versions; fixed in 0.7.1\n- pyshop (PyPI): affected all versions; fixed in 0.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1630/ (Markdown: https://insights.sbomify.com/CVE-2013-1630/index.md)","id":"CVE-2013-1630","markdown":"https://insights.sbomify.com/CVE-2013-1630/index.md","name":"CVE-2013-1630","record":{"aliases":["GHSA-f594-f3v3-g649","PYSEC-2013-10"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python package manager","requires_auth":"none","summary":"Man-in-the-middle attackers can execute arbitrary code by intercepting unencrypted package downloads from PyPI in pyshop.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pyshop","vendor":"guillaume_gauvrit"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"pyshop before 0.7.1 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a download operation.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pyshop vulnerable to man-in-the-middle attacks due to using HTTP to retrieve packages from the PyPI repository","id":"CVE-2013-1630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2013"},"n_packages":3,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2013-1631"},"packages":[{"ecosystem":"PyPI","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"pyshop","purl":null,"source":"GHSA-f594-f3v3-g649"},{"ecosystem":"PyPI","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"pyshop","purl":"pkg:pypi/pyshop","source":"GHSA-f594-f3v3-g649"},{"ecosystem":"PyPI","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"pyshop","purl":"pkg:pypi/pyshop","source":"PYSEC-2013-10"}],"prev":{"headline":"Improper Input Validation in pip","id":"CVE-2013-1629"},"products":["n/a"],"published":"2013-08-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can execute arbitrary code by intercepting unencrypted package downloads from PyPI in pyshop.","url":"https://insights.sbomify.com/CVE-2013-1630/"}