{"answers":{"affected":"3 open source packages ship an affected version, including setuptools. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1633 in the wild and no public exploit code.","fix":"Upgrade setuptools to 0.7 or later.","what":"CVE-2013-1633 is a medium-severity vulnerability in n/a, published on 6 Aug 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-1633 and fix it if it is affected.\n\nWhat it is: CVE-2013-1633 is a medium-severity vulnerability in n/a, published on 6 Aug 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-1633 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- setuptools (PyPI): affected all versions; fixed in 0.7\n- setuptools (PyPI): affected all versions; fixed in 0.7\n- setuptools (PyPI): affected all versions; fixed in 0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1633/ (Markdown: https://insights.sbomify.com/CVE-2013-1633/index.md)","id":"CVE-2013-1633","markdown":"https://insights.sbomify.com/CVE-2013-1633/index.md","name":"CVE-2013-1633","record":{"aliases":["AZL-41159","GHSA-27x4-j476-jp5f","MGASA-2013-0274","PYSEC-2013-22"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python setuptools","requires_auth":"none","summary":"Man-in-the-middle attackers can execute arbitrary code by intercepting unverified HTTP package downloads during default setuptools usage.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"setuptools","vendor":"python"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"easy_install in setuptools before 0.7 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to the default use of the product.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Setuptools vulnerable to Man-in-the-middle attacks","id":"CVE-2013-1633","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2013"},"n_packages":3,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2013-1634"},"packages":[{"ecosystem":"PyPI","fixed":["0.7"],"introduced":["0"],"last_affected":[],"package":"setuptools","purl":null,"source":"GHSA-27x4-j476-jp5f"},{"ecosystem":"PyPI","fixed":["0.7"],"introduced":["0"],"last_affected":[],"package":"setuptools","purl":"pkg:pypi/setuptools","source":"GHSA-27x4-j476-jp5f"},{"ecosystem":"PyPI","fixed":["0.7"],"introduced":["0"],"last_affected":[],"package":"setuptools","purl":"pkg:pypi/setuptools","source":"PYSEC-2013-22"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2013-1631"},"products":["n/a"],"published":"2013-08-06","related":[{"cvss_score":6.1,"headline":"setuptools: MANIFEST.in exclusion bypass in sdist via Unicode normalization collision (NFC/NFD) on macOS APFS/HFS+","id":"CVE-2026-59890","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.9,"headline":"pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS)","id":"CVE-2022-40897","kev_date_added":null,"published":"2022-12-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can execute arbitrary code by intercepting unverified HTTP package downloads during default setuptools usage.","url":"https://insights.sbomify.com/CVE-2013-1633/"}