# CVE-2013-1633: Setuptools vulnerable to Man-in-the-middle attacks

> Man-in-the-middle attackers can execute arbitrary code by intercepting unverified HTTP package downloads during default setuptools usage.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2013
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-41159, GHSA-27x4-j476-jp5f, MGASA-2013-0274, PYSEC-2013-22

## What is CVE-2013-1633?

CVE-2013-1633 is a medium-severity vulnerability in n/a, published on 6 Aug 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

easy_install in setuptools before 0.7 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to the default use of the product.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-1633?

3 open source packages ship an affected version, including setuptools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `setuptools` | PyPI | All versions | 0.7 |
| `setuptools` | PyPI | All versions | 0.7 |
| `setuptools` | PyPI | All versions | 0.7 |

Products: Python Setuptools.

## How do I fix CVE-2013-1633?

Upgrade setuptools to 0.7 or later.

## Is CVE-2013-1633 being exploited?

There is no known exploitation of CVE-2013-1633 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-59890](https://insights.sbomify.com/CVE-2026-59890/): setuptools: MANIFEST.in exclusion bypass in sdist via Unicode normalization collision (NFC/NFD) on macOS APFS/HFS+ (medium 6.1)
- [CVE-2022-40897](https://insights.sbomify.com/CVE-2022-40897/): pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS) (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1633 and fix it if it is affected.

What it is: CVE-2013-1633 is a medium-severity vulnerability in n/a, published on 6 Aug 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-1633 in the wild and no public exploit code.

Affected packages and fixed versions:
- setuptools (PyPI): affected all versions; fixed in 0.7
- setuptools (PyPI): affected all versions; fixed in 0.7
- setuptools (PyPI): affected all versions; fixed in 0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1633/ (Markdown: https://insights.sbomify.com/CVE-2013-1633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1633
- OSV: https://osv.dev/vulnerability/CVE-2013-1633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1633/
Summaries are generated and may contain mistakes; the official description above is the record.
