CVE-2013-1655 Puppet Improper Input Validation vulnerability
Remote attackers can execute arbitrary code on Puppet servers via serialized attributes, requiring immediate upgrades.
- Exploited in the wild
- Not known
- Login needed
- Not stated
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-1655?
CVE-2013-1655 is a high-severity unsafe deserialization vulnerability in Puppet Puppet Enterprise, published on 20 Mar 2013. It can be exploited over the network, with no action from the victim.
Official description
Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."
Weakness: CWE-20
Which versions are affected by CVE-2013-1655?
4 open source packages ship an affected version, including puppet. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | From 2.7.0 | 2.7.21 |
puppet RubyGems | From 2.7.0 | 2.7.21 |
puppet RubyGems | From 3.1.0 | 3.1.1 |
puppet RubyGems | From 3.1.0 | 3.1.1 |
Products include Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet.
How do I fix CVE-2013-1655?
Upgrade puppet to a fixed version for your release line: 2.7.21 or 3.1.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2013-1655 being exploited?
There is no known exploitation of CVE-2013-1655 in the wild and no public exploit code.
Other vulnerabilities in Puppet Puppet Enterprise
Sources
Also known as DEBIAN-CVE-2013-1655, GHSA-574q-fxfj-wv6h.